summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-27 12:48:45 +0300
committerDimitris Kiziridis2020-07-27 12:48:45 +0300
commite25ae4e3dc5da0ae6a68e3ce35b40579a64d9b43 (patch)
treea538b01d1a7952964b9d2270187a5cb459d161bd
downloadaur-e25ae4e3dc5da0ae6a68e3ce35b40579a64d9b43.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f35745d4068
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hoverfly
+ pkgdesc = Lightweight service virtualization/API simulation tool for developers and testers
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://hoverfly.io
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ depends = glibc
+ provides = hoverfly
+ conflicts = hoverfly-bin
+ conflicts = hoverfly-git
+ source = hoverfly-1.3.0.tar.gz::https://github.com/SpectoLabs/hoverfly/archive/v1.3.0.tar.gz
+ sha256sums = 48fe07d44eb6070e84f5670155d4aa5783ff0500522cc9ab1c7396f2ed9c73a8
+
+pkgname = hoverfly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e37a225a8ae7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=hoverfly
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Lightweight service virtualization/API simulation tool for developers and testers"
+arch=('x86_64')
+url='https://hoverfly.io'
+license=('Apache')
+provides=('hoverfly')
+conflicts=('hoverfly-bin' 'hoverfly-git')
+depends=('glibc')
+makedepends=('go')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/SpectoLabs/hoverfly/archive/v${pkgver}.tar.gz")
+sha256sums=('48fe07d44eb6070e84f5670155d4aa5783ff0500522cc9ab1c7396f2ed9c73a8')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ mkdir -p build/
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o build ./...
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 build/hoverctl -t "${pkgdir}/usr/bin"
+ install -Dm755 build/hoverfly -t "${pkgdir}/usr/bin"
+} \ No newline at end of file