summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:58:13 +0200
committerLubosz Sarnecki2015-06-22 22:58:13 +0200
commitf31da73b0d7ec30b6d5ef3b8eac5bc0765a09078 (patch)
treeab91c80fb893111fcddb827754d9d855edfef264
downloadaur-f31da73b0d7ec30b6d5ef3b8eac5bc0765a09078.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
3 files changed, 52 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..27f6fca66d9e
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = hovr-git
+ pkgdesc = A Blender Game Engine Demo for the Oculus Rift and the Nintendo Balance Board
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/lubosz/python-rift
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = blender
+ depends = python-balanceboard-git
+ depends = python-rift-git
+ source = git+https://github.com/lubosz/hovr.git
+
+pkgname = hovr-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef649d8fac36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hovr-git
+ pkgdesc = A Blender Game Engine Demo for the Oculus Rift and the Nintendo Balance Board
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/lubosz/python-rift
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = blender
+ depends = python-balanceboard-git
+ depends = python-rift-git
+ source = git+https://github.com/lubosz/hovr.git
+ md5sums = SKIP
+
+pkgname = hovr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99a1712a0b0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+_realname=hovr
+pkgname=$_realname-git
+pkgver=1
+pkgrel=1
+pkgdesc="A Blender Game Engine Demo for the Oculus Rift and the Nintendo Balance Board"
+arch=('i686' 'x86_64')
+url="https://github.com/lubosz/python-rift"
+license=('GPLv3')
+depends=('blender' 'python-balanceboard-git' 'python-rift-git')
+source=("git+https://github.com/lubosz/$_realname.git")
+md5sums=('SKIP')
+
+package() {
+ cd $_realname
+ mkdir -p $pkgdir/usr/share/$_realname/
+ mkdir -p $pkgdir/usr/bin/
+ cp * $pkgdir/usr/share/$_realname/ -R
+ echo "blender /usr/share/$_realname/HoVR.blend" > $pkgdir/usr/bin/hovr
+ chmod +x $pkgdir/usr/bin/hovr
+}