summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBhanupong Petchlert2015-06-08 23:56:24 +0700
committerBhanupong Petchlert2015-06-08 23:56:24 +0700
commitc5cd679cbd6bf1a35329e242eeb018af67efc08c (patch)
tree49f667902d662bd18fc2fbf5830e31d6da9e5178
downloadaur-c5cd679cbd6bf1a35329e242eeb018af67efc08c.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f62605ab99d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = howdoi-git
+ pkgdesc = A code search tool. (from git, build for python 3)
+ pkgver = 1.1.7.210.14116ff
+ pkgrel = 1
+ url = https://github.com/gleitz/howdoi
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-cssselect
+ depends = python-lxml
+ depends = python-pyquery
+ depends = python-requests
+ depends = python-requests-cache
+ depends = python-pygments
+ conflicts = python2-howdoi
+ conflicts = howdoi
+ source = howdoi::git+https://github.com/gleitz/howdoi.git
+ md5sums = SKIP
+
+pkgname = howdoi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8db92c9f7001
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Bhanupong Petchlert <bpetlert@gmail.com>
+
+pkgname=howdoi-git
+_pkgname="howdoi"
+pkgver=1.1.7.210.14116ff
+pkgrel=1
+pkgdesc="A code search tool. (from git, build for python 3)"
+arch=(any)
+url=("https://github.com/gleitz/howdoi")
+license=('MIT')
+depends=(
+ 'python'
+ 'python-cssselect'
+ 'python-lxml'
+ 'python-pyquery'
+ 'python-requests'
+ 'python-requests-cache'
+ 'python-pygments'
+)
+conflicts=('python2-howdoi' 'howdoi')
+source=("${_pkgname}::git+https://github.com/gleitz/howdoi.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ _releasever=$(head -n1 CHANGES.txt)
+ revision="$(git rev-list --count HEAD)"
+ changeset="$(git log -1 --pretty=format:%h)"
+ echo "${_releasever}.${revision}.${changeset}"
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ python setup.py install --root=$pkgdir --optimize=1
+}