summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklyn Tackitt2020-07-01 08:16:24 -0700
committerFranklyn Tackitt2020-07-01 08:21:42 -0700
commite0e3f57656908afd65ad5707abac9fb7381d3f2f (patch)
tree38e918b208e2e535cc973296de43f791833da0b5
parent871acc9f46249374b2369e2ea8af99f600b3b078 (diff)
downloadaur-e0e3f57656908afd65ad5707abac9fb7381d3f2f.tar.gz
Update to v2.6.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5327a28f392..b1a0539727df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = howdy
pkgdesc = Windows Hello for Linux
- pkgver = 2.5.1
- pkgrel = 2
+ pkgver = 2.6.0
+ pkgrel = 1
url = https://github.com/boltgolt/howdy
arch = x86_64
license = MIT
@@ -11,7 +11,6 @@ pkgbase = howdy
depends = opencv
depends = hdf5
depends = pam-python
- depends = python2
depends = python3
depends = python-pillow
depends = python-dlib
@@ -20,11 +19,11 @@ pkgbase = howdy
depends = python-click
depends = python-numpy
backup = usr/lib/security/howdy/config.ini
- source = https://github.com/boltgolt/howdy/archive/v2.5.1.tar.gz
+ source = https://github.com/boltgolt/howdy/archive/v2.6.0.tar.gz
source = https://github.com/davisking/dlib-models/raw/master/dlib_face_recognition_resnet_model_v1.dat.bz2
source = https://github.com/davisking/dlib-models/raw/master/mmod_human_face_detector.dat.bz2
source = https://github.com/davisking/dlib-models/raw/master/shape_predictor_5_face_landmarks.dat.bz2
- sha256sums = 596c8d947422e6d419746784f900a4af931a6fc647e1324913c6ce66a146bf82
+ sha256sums = 5bac0f32cff1358ee06d2d33a50c3cbbb5f06973747343193ce7d9926c53de23
sha256sums = abb1f61041e434465855ce81c2bd546e830d28bcbed8d27ffbe5bb408b11553a
sha256sums = db9e9e40f092c118d5eb3e643935b216838170793559515541c56a2b50d9fc84
sha256sums = 6e787bbebf5c9efdb793f6cd1f023230c4413306605f24f299f12869f95aa472
diff --git a/PKGBUILD b/PKGBUILD
index 71f1ca2a7eaa..eb4a1418ec77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
+# Maintainer: Frank Tackitt <frank@tackitt.net>
# Maintainer: boltgolt <boltgolt@gmail.com>
-# Co-Maintainer: kagerufu <kage.urufu@gmail.com>
# Co-Maintainer: Raymo111 <hi@raymond.li>
# Contributor: Kelley McChesney <kelley@kelleymcchesney.us>
pkgname=howdy
-pkgver=2.5.1
-pkgrel=2
+pkgver=2.6.0
+pkgrel=1
pkgdesc="Windows Hello for Linux"
arch=('x86_64')
url="https://github.com/boltgolt/howdy"
@@ -14,7 +14,6 @@ depends=(
'opencv'
'hdf5'
'pam-python'
- 'python2'
'python3'
'python-pillow'
'python-dlib'
@@ -35,26 +34,24 @@ source=(
"https://github.com/davisking/dlib-models/raw/master/mmod_human_face_detector.dat.bz2"
"https://github.com/davisking/dlib-models/raw/master/shape_predictor_5_face_landmarks.dat.bz2"
)
-sha256sums=(
- '596c8d947422e6d419746784f900a4af931a6fc647e1324913c6ce66a146bf82'
- 'abb1f61041e434465855ce81c2bd546e830d28bcbed8d27ffbe5bb408b11553a'
- 'db9e9e40f092c118d5eb3e643935b216838170793559515541c56a2b50d9fc84'
- '6e787bbebf5c9efdb793f6cd1f023230c4413306605f24f299f12869f95aa472'
-)
+sha256sums=('5bac0f32cff1358ee06d2d33a50c3cbbb5f06973747343193ce7d9926c53de23'
+ 'abb1f61041e434465855ce81c2bd546e830d28bcbed8d27ffbe5bb408b11553a'
+ 'db9e9e40f092c118d5eb3e643935b216838170793559515541c56a2b50d9fc84'
+ '6e787bbebf5c9efdb793f6cd1f023230c4413306605f24f299f12869f95aa472')
package() {
# Installing the proper license files and the rest of howdy
cd howdy-$pkgver
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
mkdir -p "$pkgdir/usr/lib/security/howdy"
- cp -rf src/* "$pkgdir/usr/lib/security/howdy"
- cp -f "${srcdir}/dlib_face_recognition_resnet_model_v1.dat" "$pkgdir/usr/lib/security/howdy/dlib-data/"
- cp -f "${srcdir}/mmod_human_face_detector.dat" "$pkgdir/usr/lib/security/howdy/dlib-data/"
- cp -f "${srcdir}/shape_predictor_5_face_landmarks.dat" "$pkgdir/usr/lib/security/howdy/dlib-data/"
+ cp -r src/* "$pkgdir/usr/lib/security/howdy"
+ cp "${srcdir}/dlib_face_recognition_resnet_model_v1.dat" "$pkgdir/usr/lib/security/howdy/dlib-data/"
+ cp "${srcdir}/mmod_human_face_detector.dat" "$pkgdir/usr/lib/security/howdy/dlib-data/"
+ cp "${srcdir}/shape_predictor_5_face_landmarks.dat" "$pkgdir/usr/lib/security/howdy/dlib-data/"
chmod 600 -R "$pkgdir/usr/lib/security/howdy"
mkdir -p "$pkgdir/usr/bin"
ln -s /lib/security/howdy/cli.py "$pkgdir/usr/bin/howdy"
chmod +x "$pkgdir/usr/lib/security/howdy/cli.py"
mkdir -p "$pkgdir/usr/share/bash-completion/completions"
- cp -f autocomplete/howdy "$pkgdir/usr/share/bash-completion/completions/howdy"
+ cp autocomplete/howdy "$pkgdir/usr/share/bash-completion/completions/howdy"
}