summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Fontenot2021-08-23 09:06:57 -0500
committerCaleb Fontenot2021-08-23 09:06:57 -0500
commitd78a5b490dff5fcb00f89d62333bb06e3e7decec (patch)
treee68285806538251e74731907862f7928b0c31804
downloadaur-d78a5b490dff5fcb00f89d62333bb06e3e7decec.tar.gz
Init
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD65
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c848cb3dac7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = howdy
+ pkgdesc = Windows Hello for Linux
+ pkgver = 2.6.1
+ pkgrel = 2
+ url = https://github.com/boltgolt/howdy
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = pkgfile
+ depends = opencv
+ depends = hdf5
+ depends = pam-python
+ depends = python
+ depends = python-pillow
+ depends = python-dlib
+ depends = python-face_recognition
+ depends = python-face_recognition_models
+ depends = python-click
+ depends = python-numpy
+ depends = python-opencv
+ backup = usr/lib/security/howdy/config.ini
+ source = https://github.com/boltgolt/howdy/archive/v2.6.1.tar.gz
+ source = https://github.com/davisking/dlib-models/raw/master/dlib_face_recognition_resnet_model_v1.dat.bz2
+ source = https://github.com/davisking/dlib-models/raw/master/mmod_human_face_detector.dat.bz2
+ source = https://github.com/davisking/dlib-models/raw/master/shape_predictor_5_face_landmarks.dat.bz2
+ sha256sums = f3f48599f78fd82b049539fcfc34de25c9435cad732697bdda94e85352964794
+ sha256sums = abb1f61041e434465855ce81c2bd546e830d28bcbed8d27ffbe5bb408b11553a
+ sha256sums = db9e9e40f092c118d5eb3e643935b216838170793559515541c56a2b50d9fc84
+ sha256sums = 6e787bbebf5c9efdb793f6cd1f023230c4413306605f24f299f12869f95aa472
+
+pkgname = howdy
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4989050fb8b7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+pkg
+src
+*.tar.gz
+*.zip
+*.tar.xz
+*.patch
+*.dat.bz2
+*.tar.zst
+howdy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86270b65b4d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Caleb Fontenot <foley2431@gmail.com>
+
+pkgname=howdy-git
+pkgver=2.6.1.r12.g95331bd
+pkgrel=1
+pkgdesc="Windows Hello for Linux"
+arch=('x86_64')
+url="https://github.com/boltgolt/howdy"
+license=('MIT')
+depends=(
+ 'opencv'
+ 'hdf5'
+ 'pam-python'
+ 'python'
+ 'python-pillow'
+ 'python-dlib'
+ 'python-face_recognition'
+ 'python-face_recognition_models'
+ 'python-click'
+ 'python-numpy'
+ 'python-opencv'
+)
+makedepends=(
+ 'cmake'
+ 'pkgfile'
+)
+conflicts=(
+ 'howdy'
+)
+provides=(
+ 'howdy'
+)
+backup=('usr/lib/security/howdy/config.ini')
+source=(
+ "git+https://github.com/boltgolt/howdy.git"
+ "https://github.com/davisking/dlib-models/raw/master/dlib_face_recognition_resnet_model_v1.dat.bz2"
+ "https://github.com/davisking/dlib-models/raw/master/mmod_human_face_detector.dat.bz2"
+ "https://github.com/davisking/dlib-models/raw/master/shape_predictor_5_face_landmarks.dat.bz2"
+)
+sha256sums=('SKIP'
+ 'abb1f61041e434465855ce81c2bd546e830d28bcbed8d27ffbe5bb408b11553a'
+ 'db9e9e40f092c118d5eb3e643935b216838170793559515541c56a2b50d9fc84'
+ '6e787bbebf5c9efdb793f6cd1f023230c4413306605f24f299f12869f95aa472')
+pkgver() {
+ cd "$srcdir/howdy"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ # Installing the proper license files and the rest of howdy
+ cd "howdy"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/howdy/LICENSE"
+ mkdir -p "${pkgdir}/usr/lib/security/howdy"
+ cp -r src/* "${pkgdir}/usr/lib/security/howdy"
+ cp "${srcdir}/dlib_face_recognition_resnet_model_v1.dat" "${pkgdir}/usr/lib/security/howdy/dlib-data/"
+ cp "${srcdir}/mmod_human_face_detector.dat" "${pkgdir}/usr/lib/security/howdy/dlib-data/"
+ cp "${srcdir}/shape_predictor_5_face_landmarks.dat" "${pkgdir}/usr/lib/security/howdy/dlib-data/"
+ chmod 600 -R "${pkgdir}/usr/lib/security/howdy"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s /lib/security/howdy/cli.py "${pkgdir}/usr/bin/howdy"
+ chmod +x "${pkgdir}/usr/lib/security/howdy/cli.py"
+ mkdir -p "${pkgdir}/usr/share/bash-completion/completions"
+ cp autocomplete/howdy "${pkgdir}/usr/share/bash-completion/completions/howdy"
+}
+