summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuki Chiba2015-06-11 16:12:43 +0900
committerYuki Chiba2015-06-11 16:12:43 +0900
commit62a43ce8621940fb079936cc075f832649cb72cb (patch)
treefca03067ce0947318f856acd9903bbfa3c0a8e39
downloadaur-62a43ce8621940fb079936cc075f832649cb72cb.tar.gz
Initial commit for AUR4
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD27
-rw-r--r--howm.install8
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b2bb8c9272c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = howm
+ pkgdesc = Hitori Otegaru Wiki Modoki: A note-taking tool on Emacs.
+ pkgver = 1.4.2
+ pkgrel = 2
+ url = http://howm.sourceforge.jp/index.html
+ install = howm.install
+ arch = any
+ groups = editors
+ license = GPL2
+ depends = emacs
+ optdepends = ruby: HTML conversion and calendar support
+ source = http://howm.sourceforge.jp/a/howm-1.4.2.tar.gz
+ md5sums = 704001b8e4031e3293fc3eb1cb08befa
+
+pkgname = howm
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a6c7fdf1414
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+howm-*/
+howm-*.tar.[gx]z
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d73758c373bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Tomohiro Takezawa <khabus {at} gmail.com>
+# Maintainer: yuki-san <yuki.from.akita {at} gmail.com>
+
+pkgname=howm
+pkgver=1.4.2
+pkgrel=2
+pkgdesc="Hitori Otegaru Wiki Modoki: A note-taking tool on Emacs."
+arch=('any')
+url="http://howm.sourceforge.jp/index.html"
+license=('GPL2')
+groups=('editors')
+depends=('emacs')
+optdepends=('ruby: HTML conversion and calendar support')
+install=${pkgname}.install
+source=("http://howm.sourceforge.jp/a/$pkgname-$pkgver.tar.gz")
+md5sums=('704001b8e4031e3293fc3eb1cb08befa')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/howm.install b/howm.install
new file mode 100644
index 000000000000..cc42e03ee42d
--- /dev/null
+++ b/howm.install
@@ -0,0 +1,8 @@
+post_install() {
+ cat << EOF
+==> Put the following in your emacs configuration file (e.g. \$HOME/.emacs) to use howm
+
+(require 'howm)
+
+EOF
+}