summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2015-06-16 12:26:35 +0200
committerAlad Wenter2015-06-16 12:26:35 +0200
commit0a75351f9a2b6ced7dd52e03a236449f02366ffa (patch)
tree58bb94ad34f07e55ced7552b345f441efd11bdc3
downloadaur-0a75351f9a2b6ced7dd52e03a236449f02366ffa.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD53
-rw-r--r--howm.install7
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7de1ddedbdd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by makepkg 4.2.1
+# Mon Mar 9 16:15:46 UTC 2015
+pkgbase = howm-x11-git
+ pkgdesc = A lightweight, tiling X11 window manager that mimics vi by offering operators, motions and modes.
+ pkgver = 0.5.29.g8879be1
+ pkgrel = 9
+ url = https://github.com/HarveyHunt/howm
+ install = howm.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ checkdepends = linux-headers
+ makedepends = git
+ depends = bash
+ depends = xcb-util-wm
+ depends = sxhkd
+ depends = cottage-git
+ provides = howm-x11
+ conflicts = howm-x11
+ options = docs
+ options = !strip
+ options = debug
+ source = git+https://github.com/HarveyHunt/howm#branch=develop
+ sha256sums = SKIP
+
+pkgname = howm-x11-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1cf4b73341c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
+
+pkgname=howm-x11-git
+_pkgname=howm
+pkgver=0.5.29.g8879be1
+pkgrel=9
+
+pkgdesc='A lightweight, tiling X11 window manager that mimics vi by offering operators, motions and modes.'
+arch=('i686' 'x86_64')
+url='https://github.com/HarveyHunt/howm'
+license=('GPL')
+
+depends=('bash' 'xcb-util-wm' 'sxhkd' 'cottage-git')
+makedepends=('git')
+checkdepends=('linux-headers')
+provides=('howm-x11')
+conflicts=('howm-x11')
+options=('!strip' 'debug')
+source=('git+https://github.com/HarveyHunt/howm#branch=develop')
+sha256sums=('SKIP')
+install=howm.install
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags | sed 's/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ make debug
+}
+
+check() {
+ cd "$_pkgname"
+ find /usr/lib/modules -name checkpatch.pl -print -quit | xargs -i cp {} .
+
+ echo "spellingtxt||disable" > spelling.txt
+ make check
+}
+
+package() {
+ cd "$_pkgname"
+
+ find examples/ -type f ! -executable -execdir \
+ install -Dm644 {} "$pkgdir"/usr/share/howm/examples/{} \;
+ find examples/ -type f -executable -execdir \
+ install -Dm755 {} "$pkgdir"/usr/share/howm/examples/{} \;
+
+ install -Dm755 bin/debug/howm "$pkgdir"/usr/bin/howm
+ install -Dm644 howm.xsession.desktop "$pkgdir"/usr/share/xsessions/howm.xsession.desktop
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/howm.install b/howm.install
new file mode 100644
index 000000000000..616ec2417af6
--- /dev/null
+++ b/howm.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "Please copy the configuration file in /usr/share/howm/examples/howmrc to ~/.config/howm/"
+}
+
+post_upgrade() {
+ post_install
+}