summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2017-09-10 21:14:18 +0200
committerAlad Wenter2017-09-10 21:14:18 +0200
commitca483140818e3c60e876d6b2f207bd17ff87e52a (patch)
tree6c634e535b749b5f1a6f3b0d5d3d932ea702c235
parentd46531b6355b3ff37ccbdf3881d1689cc6632ed2 (diff)
downloadaur-ca483140818e3c60e876d6b2f207bd17ff87e52a.tar.gz
howm-x11-git: fix examples
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 8 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 329398cc3461..7ba7e67bfd0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
# Generated by mksrcinfo v8
-# Fri Jan 29 18:11:13 UTC 2016
+# Sun Sep 10 19:14:07 UTC 2017
pkgbase = howm-x11-git
pkgdesc = A lightweight, tiling X11 window manager that mimics vi by offering operators, motions and modes.
- pkgver = 0.5.102.gd326a44
+ pkgver = 0.5.1.74.gd810ad1
pkgrel = 1
url = https://github.com/HarveyHunt/howm
- install = howm.install
arch = i686
arch = x86_64
license = GPL
makedepends = git
- depends = bash
depends = xcb-util-wm
depends = sxhkd
depends = cottage-git
provides = howm-x11
conflicts = howm-x11
- options = debug
source = howm-x11-git::git+https://github.com/HarveyHunt/howm#branch=develop
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3b7064af8dcc..844a620448b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,17 @@
-# Maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
-
+# Maintainer: Alad Wenter <alad@mailbox.org>
pkgname=howm-x11-git
-pkgver=0.5.102.gd326a44
+pkgver=0.5.1.74.gd810ad1
pkgrel=1
-
pkgdesc='A lightweight, tiling X11 window manager that mimics vi by offering operators, motions and modes.'
url='https://github.com/HarveyHunt/howm'
license=('GPL')
arch=('i686' 'x86_64')
-
-depends=('bash' 'xcb-util-wm' 'sxhkd' 'cottage-git')
+depends=('xcb-util-wm' 'sxhkd' 'cottage-git')
makedepends=('git')
provides=('howm-x11')
conflicts=('howm-x11')
-
-options=('debug')
source=("$pkgname::git+https://github.com/HarveyHunt/howm#branch=develop")
sha256sums=('SKIP')
-install=howm.install
pkgver() {
cd "$pkgname"
@@ -31,13 +25,11 @@ build() {
package() {
cd "$pkgname"
- find examples/ -type f ! -executable -execdir \
- install -Dm644 {} "$pkgdir"/usr/share/howm/examples/{} \;
- find examples/ -type f -executable -execdir \
- install -Dm755 {} "$pkgdir"/usr/share/howm/examples/{} \;
-
install -Dm755 bin/debug/howm "$pkgdir"/usr/bin/howm
install -Dm644 howm.xsession.desktop "$pkgdir"/usr/share/xsessions/howm.xsession.desktop
+
+ mkdir -p "$pkgdir"/usr/share/howm/examples
+ cp -a examples/* "$pkgdir"/usr/share/howm/examples/
}
# vim:set ts=2 sw=2 et: