summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2018-12-13 08:11:37 +0100
committeraksr2018-12-13 08:11:37 +0100
commit486bfbac236f1c38ef86ff34969778b67311d4c9 (patch)
treec538929c7259477794c97a82106607efabb63593
downloadaur-486bfbac236f1c38ef86ff34969778b67311d4c9.tar.gz
Start.
-rw-r--r--.SRCINFO17
l---------.gitignore1
-rw-r--r--PKGBUILD44
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfd792da97f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Dec 13 07:11:37 UTC 2018
+pkgbase = hp-git
+ pkgdesc = Modern version of the GT SWT "hp" RPN calculator
+ pkgver = r21.5b743b7
+ pkgrel = 1
+ url = https://github.com/arnoldrobbins/hp
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ conflicts = hp
+ source = hp-git::git+https://github.com/arnoldrobbins/hp
+ md5sums = SKIP
+
+pkgname = hp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 120000
index 000000000000..25c0564928e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/home/aksr/arch/pkg/.gitignore \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..252255d9154c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=hp-git
+pkgver=r21.5b743b7
+pkgrel=1
+epoch=
+pkgdesc="Modern version of the GT SWT \"hp\" RPN calculator"
+arch=('i686' 'x86_64')
+url="https://github.com/arnoldrobbins/hp"
+license=('GPL3')
+groups=()
+depends=()
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=("${pkgname%-*}")
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+$url")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/{bin,share/{doc,man/man1}}
+ install -D -m755 hp $pkgdir/usr/bin/hp
+ install -D -m755 hp.awk $pkgdir/usr/bin/hp.awk
+ install -D -m644 README $pkgdir/usr/share/doc/${pkgname%-*}/README
+ install -D -m644 hp.1 $pkgdir/usr/share/man/man1/hp.1
+}
+