summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2015-06-09 11:04:12 +0200
committerMassimiliano Torromeo2015-06-09 11:04:12 +0200
commit3546ffc7cd17feb4c1bdaca50ff385d01182026f (patch)
treea509af3658c5380184738c4f0c2587467403a83e
downloadaur-3546ffc7cd17feb4c1bdaca50ff385d01182026f.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
-rw-r--r--hpasmd.service11
-rw-r--r--hpasrd.service13
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa71b4c79ad7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = hp-health
+ pkgdesc = HP System Health Application and Command line Utility Package
+ pkgver = 9.50_1628
+ pkgrel = 3
+ url = http://downloads.linux.hp.com/SDR/downloads/mcp
+ arch = i686
+ arch = x86_64
+ groups = hpproliant
+ license = CUSTOM
+ depends = bash
+ depends = dmidecode
+ depends = pciutils
+ source = http://downloads.linux.hp.com/SDR/downloads/mcp/centos/6//current/hp-health-9.50-1628.32.rhel6..rpm
+ source = hpasmd.service
+ source = hpasrd.service
+ sha256sums = 8dc1247dded64d620d72b02384997d3e6bf582233fa766ee9bd35c7ef17ecaed
+ sha256sums = 6db979dcc293bb4e73593e19e467c45a3f66bdab7df395ccb63218926aeb6050
+ sha256sums = 78913f4ab8230eafad68d9bfc69075ce81ccf06e7b77864f4a0aa73226d2cc90
+
+pkgname = hp-health
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89810cadb65f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=hp-health
+pkgver=9.50_1628
+pkgrel=3
+pkgdesc="HP System Health Application and Command line Utility Package"
+arch=(i686 x86_64)
+url="http://downloads.linux.hp.com/SDR/downloads/mcp"
+depends=(bash dmidecode pciutils)
+groups=(hpproliant)
+license=("CUSTOM")
+
+sha256sums=('8dc1247dded64d620d72b02384997d3e6bf582233fa766ee9bd35c7ef17ecaed'
+ '6db979dcc293bb4e73593e19e467c45a3f66bdab7df395ccb63218926aeb6050'
+ '78913f4ab8230eafad68d9bfc69075ce81ccf06e7b77864f4a0aa73226d2cc90')
+rpmrel=32
+if [ "$CARCH" = "i686" ]; then
+ rpmrel=33
+ sha256sums[0]='7ee31c9843e5e8b06d42143c5b5f167fef5c62e5f22b759bd2da7caf84ce48ca'
+fi
+
+source=(http://downloads.linux.hp.com/SDR/downloads/mcp/centos/6/$CARCH/current/$pkgname-${pkgver//_/-}.$rpmrel.rhel6.$CARCH.rpm
+ hpasmd.service
+ hpasrd.service)
+
+package() {
+ cd "$srcdir"
+ cp -a opt usr var "$pkgdir"
+ cp -a sbin "$pkgdir"/usr/bin
+
+ cd "$pkgdir"/usr
+ [ -d lib64 ] && mv lib64 lib
+
+ install -Dm644 "$srcdir"/hpasmd.service "$pkgdir"/usr/lib/systemd/system/hpasmd.service
+ install -Dm644 "$srcdir"/hpasrd.service "$pkgdir"/usr/lib/systemd/system/hpasrd.service
+}
diff --git a/hpasmd.service b/hpasmd.service
new file mode 100644
index 000000000000..bd461f03dc85
--- /dev/null
+++ b/hpasmd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Proliant System Health Monitor
+
+[Service]
+Type=forking
+ExecStartPre=-/usr/bin/modprobe ipmi_devintf
+ExecStart=/opt/hp/hp-health/bin/hpasmlited -f /dev/ipmi0
+Restart=on-abort
+
+[Install]
+WantedBy=multi-user.target
diff --git a/hpasrd.service b/hpasrd.service
new file mode 100644
index 000000000000..4baa4a307d96
--- /dev/null
+++ b/hpasrd.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=HP Advanced Server Recovery Daemon
+Requires=hpasmd.service
+After=hpasmd.service
+
+[Service]
+Type=forking
+ExecStart=/opt/hp/hp-health/bin/hp-asrd
+Restart=on-abort
+
+
+[Install]
+WantedBy=multi-user.target