summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuint Guvernator2018-11-14 20:01:20 -0500
committerQuint Guvernator2018-11-14 20:01:20 -0500
commite388095fd56455c7ab54666197f439e8a94cd75a (patch)
treeeebae1c6955fac7113eaa19b95cf214d83b723fa
parent19a7e94e03db24c0f3c6e9a6738c32b215ec5a9a (diff)
downloadaur-e388095fd56455c7ab54666197f439e8a94cd75a.tar.gz
verify checksums of supporting files
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83e6a05975d4..410a9ad57b8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,11 @@ pkgbase = hp15c
depends = tcl
depends = tk
source = hp15c-4.0.0.zip::https://drive.google.com/uc?export=download&id=1ewFXi6PPRsiPJESUq5A2Gp83NYSYVYKr
+ source = 01-hp15c-arch-docs.patch
+ source = hp15c_runner.sh
md5sums = c90cc630d9e5bdf70912f8cd754cc2cc
+ md5sums = cb4a8e759f94860744057c20f90244e4
+ md5sums = bdf3ff02949e3c716b782e8cec9ee8a1
pkgname = hp15c
diff --git a/PKGBUILD b/PKGBUILD
index 9f9d0b07a823..34635612d5b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,18 @@ url="http://hp-15c.homepage.t-online.de/content_web.htm"
arch=('any')
license=('GPL3')
depends=('tcl' 'tk')
-source=("$pkgname-$pkgver.zip::https://drive.google.com/uc?export=download&id=1ewFXi6PPRsiPJESUq5A2Gp83NYSYVYKr")
-md5sums=('c90cc630d9e5bdf70912f8cd754cc2cc')
+source=(
+ "$pkgname-$pkgver.zip::https://drive.google.com/uc?export=download&id=1ewFXi6PPRsiPJESUq5A2Gp83NYSYVYKr"
+ "01-hp15c-arch-docs.patch"
+ "hp15c_runner.sh"
+)
+md5sums=('c90cc630d9e5bdf70912f8cd754cc2cc'
+ 'cb4a8e759f94860744057c20f90244e4'
+ 'bdf3ff02949e3c716b782e8cec9ee8a1')
prepare() {
# patch location of help files to match Arch standards
- patch -p1 -i '../01-hp15c-arch-docs.patch'
+ patch -p1 -i "$srcdir/01-hp15c-arch-docs.patch"
}
package() {
@@ -30,7 +36,7 @@ package() {
# runs script in proper directory
cp HP-15C.tcl -t "$pkgdir/usr/lib/$pkgname/"
- install -D ../hp15c_runner.sh "$pkgdir/usr/bin/hp15c"
+ install -D "$srcdir/hp15c_runner.sh" "$pkgdir/usr/bin/hp15c"
}
# vim:set ts=4 sw=4 ft=sh et: