summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2022-11-03 00:29:53 +0000
committerFlorian Hülsmann2022-11-03 00:29:53 +0000
commit58b857d7b6e619bc81c10bf0f1cf8a2b934dbea6 (patch)
tree434e5499462125083732a5b04b99a13bc53d63d9
parent44517287a493b3120cf1fe8e817f7d40dfd4320b (diff)
downloadaur-58b857d7b6e619bc81c10bf0f1cf8a2b934dbea6.tar.gz
update hpklinux to 4.20.38 (#148)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
-rw-r--r--build-flags.patch98
3 files changed, 13 insertions, 120 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50c1b52b6f09..09ffc49f26e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hpklinux
pkgdesc = AudioScience HPI (ASIHPI) user space libraries and tools
- pkgver = 4.20.36
- pkgrel = 2
+ pkgver = 4.20.38
+ pkgrel = 1
url = https://www.audioscience.com/internet/download/linux_drivers.htm
arch = x86_64
arch = aarch64
@@ -11,10 +11,9 @@ pkgbase = hpklinux
makedepends = python-setuptools
depends = glibc
optdepends = python: for python bindings
+ optdepends = python-docopt: for dab_data and dabtest scripts
provides = python-audioscience
- source = https://www.audioscience.com/internet/download/drivers/released/v4/20/36/hpklinux_4.20.36-g76c09bc.tar.gz
- source = build-flags.patch
- sha256sums = 3d3795b01f6181d8e51f78ca888519023cbdc1d83dac2fe0ae74fd6c43c7331d
- sha256sums = 92d99042bf8747024110964481afa4b05f67e25e2553c31d47b0277902048031
+ source = https://www.audioscience.com/internet/download/drivers/released/v4/20/38/hpklinux_4.20.38.tar.gz
+ sha256sums = 60bd9e8847a92bd4b280929cbca61ad4b2ae8d0b7f71ecf8c3db44bcd1e8ae03
pkgname = hpklinux
diff --git a/PKGBUILD b/PKGBUILD
index feec26a5b783..e3948ae6381e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,8 @@
# Contributor: Florian Hülsmann <fh@cbix.de>
pkgname=hpklinux
-_fullver=4.20.36-g76c09bc
-pkgver=${_fullver%-*}
-pkgrel=2
+pkgver=4.20.38
+pkgrel=1
pkgdesc='AudioScience HPI (ASIHPI) user space libraries and tools'
arch=(x86_64 aarch64)
url='https://www.audioscience.com/internet/download/linux_drivers.htm'
@@ -13,27 +12,20 @@ groups=(pro-audio)
provides=(python-audioscience)
depends=(glibc)
makedepends=(python-setuptools)
-optdepends=('python: for python bindings')
-source=("https://www.audioscience.com/internet/download/drivers/released/v${pkgver//./\/}/${pkgname}_$_fullver.tar.gz"
- 'build-flags.patch')
-sha256sums=('3d3795b01f6181d8e51f78ca888519023cbdc1d83dac2fe0ae74fd6c43c7331d'
- '92d99042bf8747024110964481afa4b05f67e25e2553c31d47b0277902048031')
-
-prepare() {
- cd ${pkgname}_$_fullver
- # fix some build flags
- patch -p1 -i ../build-flags.patch
-}
+optdepends=('python: for python bindings'
+ 'python-docopt: for dab_data and dabtest scripts')
+source=("https://www.audioscience.com/internet/download/drivers/released/v${pkgver//./\/}/${pkgname}_$pkgver.tar.gz")
+sha256sums=('60bd9e8847a92bd4b280929cbca61ad4b2ae8d0b7f71ecf8c3db44bcd1e8ae03')
build() {
- cd ${pkgname}_$_fullver
+ cd ${pkgname}_$pkgver
make -C hpi-lib
make -C hpi-cli-apps
make -C asi-python build
}
package() {
- cd ${pkgname}_$_fullver
+ cd ${pkgname}_$pkgver
make DESTDIR="$pkgdir" install-prefix=/usr -C hpi-lib install
make DESTDIR="$pkgdir" install-prefix=/usr -C hpi-cli-apps install
make CMD_OPTS="--root='$pkgdir' --skip-build --optimize=1" -C asi-python install
diff --git a/build-flags.patch b/build-flags.patch
deleted file mode 100644
index a3ecd63a5993..000000000000
--- a/build-flags.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-diff -aur a/hpi-cli-apps/Makefile b/hpi-cli-apps/Makefile
---- a/hpi-cli-apps/Makefile 2021-10-19 20:33:01.000000000 +0200
-+++ b/hpi-cli-apps/Makefile 2022-04-30 11:07:14.963316255 +0200
-@@ -33,12 +33,12 @@
- LD = $(CROSS_COMPILE)ld
-
- #WARNFULL_CFLAGS = -Wextra -pedantic -std=gnu99 -Wconversion
--CFLAGS = -pipe -g -O2 -Wall -DHPI_OS_LINUX -DHPI_BUILD_EXCLUDE_ALL_DEPRECATED \
-+CFLAGS += -pipe -g -O2 -Wall -DHPI_OS_LINUX -DHPI_BUILD_EXCLUDE_ALL_DEPRECATED \
- $(WARNFULL_CFLAGS)
-
- # Find out if this is a 64-bit build
- ar_gcc_arch=$(shell $(CC) -dumpmachine | awk -F- '{ print $$1 }')
--ifeq ($(ar_gcc_arch),x86_64)
-+ifneq (,$(filter $(ar_gcc_arch),x86_64 aarch64))
- CFLAGS += -D HPI_BUILD_64BIT
- endif
-
-@@ -48,31 +48,31 @@
- bin-install-dir ?= $(install-prefix)/bin
-
- asihpirds: $(asihpirds-srcs)
-- $(CC) $(CFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-+ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-
- asihpi_si4688: $(asihpi-si4688-srcs)
-- $(CC) $(CFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-+ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-
- asihpitest: $(asihpitest-srcs)
-- $(CC) $(CFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-+ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-
- asihpirec: $(asihpirec-srcs)
-- $(CC) $(CFLAGS) $(INCLUDES) -DASIHPIREC -o $@ $^ -lhpi -lm
-+ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDES) -DASIHPIREC -o $@ $^ -lhpi -lm
-
- asihpiplay: $(asihpirec-srcs)
-- $(CC) $(CFLAGS) $(INCLUDES) -DASIHPIPLAY -o $@ $^ -lhpi -lm
-+ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDES) -DASIHPIPLAY -o $@ $^ -lhpi -lm
-
- asihpitune: $(asihpitune-srcs)
-- $(CC) $(CFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-+ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-
- asihpiassert: $(asihpiassert-srcs)
-- $(CC) $(CFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-+ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-
- asihpibl: $(asihpibl-srcs)
-- $(CC) $(CFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-+ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDES) -o $@ $^ -lhpi -lm
-
- asi_firmware_updater: $(asi-firmware-updater-srcs)
-- $(CC) $(CFLAGS) $(INCLUDES) -D HPI_BUILD_INCLUDE_INTERNAL -o $@ $^ -lhpiudp -lm -lpthread
-+ $(CC) $(CFLAGS) $(LDFLAGS) $(INCLUDES) -D HPI_BUILD_INCLUDE_INTERNAL -o $@ $^ -lhpiudp -lm -lpthread
-
- setup: $(src-dist-files)
-
-diff -aur a/hpi-lib/Makefile b/hpi-lib/Makefile
---- a/hpi-lib/Makefile 2021-10-19 20:33:01.000000000 +0200
-+++ b/hpi-lib/Makefile 2022-04-30 11:03:32.436651256 +0200
-@@ -52,7 +52,7 @@
-
- # Find out if this is a 64-bit build
- ar_gcc_arch=$(shell $(CC) -dumpmachine | awk -F- '{ print $$1 }')
--ifeq ($(ar_gcc_arch),x86_64)
-+ifneq (,$(filter $(ar_gcc_arch),x86_64 aarch64))
- CFLAGS += -D HPI_BUILD_64BIT
- lib-install-dir-candidates = $(install-prefix)/lib64 $(install-prefix)/lib
- else
-@@ -83,7 +83,7 @@
- $(AR) $(ARFLAGS) $@ $^
- libhpi.so: $(libhpi-objs)
- -rm -f $@
-- $(CC) --shared -fPIC -Wl,-soname,$@.$(LIB_VER_MAJOR) $^ -lm -lrt -o $@.$(lib-version-suffix)
-+ $(CC) $(LDFLAGS) --shared -fPIC -Wl,-soname,$@.$(LIB_VER_MAJOR) $^ -lm -lrt -o $@.$(lib-version-suffix)
- ln -sf $@.$(lib-version-suffix) $@.$(LIB_VER_MAJOR)
- ln -sf $@.$(lib-version-suffix) $@
-
-@@ -99,7 +99,7 @@
- $(AR) $(ARFLAGS) $@ $^
- libhpiudp.so: $(libhpiudp-objs)
- -rm -f $@
-- $(CC) --shared -fPIC -Wl,-soname,$@.$(LIB_VER_MAJOR) $^ -lm -lrt -lpthread -o $@.$(lib-version-suffix)
-+ $(CC) $(LDFLAGS) --shared -fPIC -Wl,-soname,$@.$(LIB_VER_MAJOR) $^ -lm -lrt -lpthread -o $@.$(lib-version-suffix)
- ln -sf $@.$(lib-version-suffix) $@.$(LIB_VER_MAJOR)
- ln -sf $@.$(lib-version-suffix) $@
-
-@@ -115,7 +115,7 @@
- $(AR) $(ARFLAGS) $@ $^
- libhpimux.so: $(libhpimux-objs)
- -rm -f $@
-- $(CC) --shared -fPIC -Wl,-soname,$@.$(LIB_VER_MAJOR) $^ -lm -lrt -lpthread -o $@.$(lib-version-suffix)
-+ $(CC) $(LDFLAGS) --shared -fPIC -Wl,-soname,$@.$(LIB_VER_MAJOR) $^ -lm -lrt -lpthread -o $@.$(lib-version-suffix)
- ln -sf $@.$(lib-version-suffix) $@.$(LIB_VER_MAJOR)
- ln -sf $@.$(lib-version-suffix) $@
-