summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Ermakov2015-12-09 20:54:28 +0300
committerAlexey Ermakov2015-12-09 20:54:28 +0300
commit27b81716c365304a874edee3ad385909863d9ed6 (patch)
tree6140a9eac47f35b224a2794357e8d47e44379e2c
parentfadc0ffe59288dae84078a5a01738894b97e0f08 (diff)
downloadaur-27b81716c365304a874edee3ad385909863d9ed6.tar.gz
Updated package:
* added missed dependency * now package builds two xhpl binaries for openmpi and mpich
-rw-r--r--PKGBUILD20
-rw-r--r--hpl-2.1-arch.patch10
2 files changed, 19 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3bcffc9d34e..e1f54e7869ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=hpl
pkgver=2.1
-pkgrel=1
+pkgrel=2
pkgdesc="A portable implementation of the high-performance Linpack benchmark for distributed-memory computers"
arch=('i686' 'x86_64')
url="http://www.netlib.org/benchmark/hpl/"
license=('custom:bsd')
-depends=('openmpi' 'cblas' 'lapack')
-makedepends=('git')
+depends=('openmpi' 'cblas' 'lapack' 'mpich')
+makedepends=('git' 'gcc-fortran')
source=("http://www.netlib.org/benchmark/hpl/hpl-${pkgver}.tar.gz" "hpl-${pkgver}-arch.patch")
-md5sums=('091aa58c3e62bdf598b403420d8387ef' 'bed9f02937529d6e30441fe4faf8ffd7')
+md5sums=('091aa58c3e62bdf598b403420d8387ef' '542fcac3a92f9860eb4dd4cb717db865')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -20,12 +20,16 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- cp setup/Make.Linux_PII_CBLAS_gm Make.mpicc
- make TOPdir="`pwd`" arch=mpicc ARCH=mpicc DESTDIR="$pkgdir/"
+ cp setup/Make.Linux_PII_CBLAS_gm Make.ompi
+ cp setup/Make.Linux_PII_CBLAS_gm Make.mpich
+
+ MPI_BIN=/usr/bin make TOPdir="`pwd`" arch=ompi ARCH=ompi
+ MPI_BIN=/opt/mpich/bin make TOPdir="`pwd`" arch=mpich ARCH=mpich
}
package(){
- install -D -m 0755 "${srcdir}/${pkgname}-${pkgver}/bin/mpicc/xhpl" "${pkgdir}/usr//bin/xhpl"
- install -D -m 0644 "${srcdir}/${pkgname}-${pkgver}/bin/mpicc/HPL.dat" "${pkgdir}/etc/hpl/HPL.dat"
+ install -D -m 0755 "${srcdir}/${pkgname}-${pkgver}/bin/ompi/xhpl" "${pkgdir}/usr/bin/xhpl-ompi"
+ install -D -m 0755 "${srcdir}/${pkgname}-${pkgver}/bin/mpich/xhpl" "${pkgdir}/usr/bin/xhpl-mpich"
+ install -D -m 0644 "${srcdir}/${pkgname}-${pkgver}/bin/ompi/HPL.dat" "${pkgdir}/etc/hpl/HPL.dat"
install -D -m 0644 "${srcdir}/${pkgname}-${pkgver}/COPYRIGHT" "${pkgdir}/usr/share/licenses/hpl/LICENSE"
}
diff --git a/hpl-2.1-arch.patch b/hpl-2.1-arch.patch
index 130dad66fdbe..323198bbb1a2 100644
--- a/hpl-2.1-arch.patch
+++ b/hpl-2.1-arch.patch
@@ -29,9 +29,12 @@ index b1c6401..997177b 100644
#
# ----------------------------------------------------------------------
# - F77 / C interface --------------------------------------------------
-@@ -168,13 +176,13 @@
+@@ -166,15 +174,15 @@
+ # - Compilers / linkers - Optimization flags ---------------------------
+ # ----------------------------------------------------------------------
#
- CC = mpicc
+-CC = mpicc
++CC = $(MPI_BIN)/mpicc
CCNOOPT = $(HPL_DEFS)
-CCFLAGS = $(HPL_DEFS) -fomit-frame-pointer -O3 -funroll-loops -W -Wall
+CCFLAGS = $(HPL_DEFS) $(CFLAGS) -fomit-frame-pointer -O3 -funroll-loops -W -Wall
@@ -39,8 +42,9 @@ index b1c6401..997177b 100644
# On some platforms, it is necessary to use the Fortran linker to find
# the Fortran internals used in the BLAS library.
#
- LINKER = mpif77
+-LINKER = mpif77
-LINKFLAGS = $(CCFLAGS)
++LINKER = $(MPI_BIN)/mpif77
+LINKFLAGS = $(CCFLAGS) -Wl,--as-needed
#
ARCHIVER = ar