summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuh2022-04-30 22:02:01 +0800
committeryuh2022-04-30 22:02:01 +0800
commitedf8341bafe26ace85198887d1bf7bd99a2138d6 (patch)
tree32ceb0d56751d32c04d03719e56cc35c38d84209
downloadaur-edf8341bafe26ace85198887d1bf7bd99a2138d6.tar.gz
3.22.4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d724acfb7844
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hplip-lite
+ pkgdesc = Only Print drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet
+ pkgver = 3.22.4
+ pkgrel = 0
+ epoch = 1
+ url = https://hplipopensource.com
+ arch = x86_64
+ license = GPL2
+ license = custom
+ optdepends = cups: for printing support
+ conflicts = hplip
+ source = https://downloads.sourceforge.net/hplip/hplip-3.22.4.tar.gz
+ sha256sums = 7be9e547c5ac40917160ef34f59f82275d1daea577067f7eeeb2ae07c7bec110
+
+pkgname = hplip-lite
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d2e9c36592b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: yuhldr <yuhldr@gmail.com>
+
+pkgname_=hplip
+pkgname="$pkgname_"-lite
+pkgver=3.22.4
+pkgrel=0
+epoch=1
+pkgdesc="Only Print drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet"
+arch=('x86_64')
+url="https://hplipopensource.com"
+license=('GPL2' 'custom')
+depends=()
+conflicts=('hplip')
+optdepends=('cups: for printing support')
+source=(https://downloads.sourceforge.net/${pkgname_}/$pkgname_-$pkgver.tar.gz)
+sha256sums=('7be9e547c5ac40917160ef34f59f82275d1daea577067f7eeeb2ae07c7bec110')
+
+prepare() {
+ cd "$pkgname_"-$pkgver
+ rm -rf ./PPD_HP
+}
+
+build() {
+ cd "$pkgname_"-$pkgver
+ ./configure --prefix=/usr \
+ --enable-lite-build \
+ --disable-doc-build \
+ --disable-fax-build \
+ --disable-network-build \
+ --disable-scan-build
+make
+}
+
+package() {
+ cd "$pkgname_"-$pkgver
+ make DESTDIR="${pkgdir}/" install
+}