summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormegadrivers2015-06-09 18:45:47 +0200
committermegadrivers2015-06-09 18:45:47 +0200
commit6a91d288fe11d044f5c7b1c30143f3f72c37c963 (patch)
tree12bf07cd98b247b7b394a04649ed1aff5653f713
downloadaur-6a91d288fe11d044f5c7b1c30143f3f72c37c963.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD58
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2eb96d332e83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = hplip-minimal
+ pkgdesc = The HP printer drivers, and not much else
+ pkgver = 3.15.4
+ pkgrel = 1
+ url = http://hplipopensource.com
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPL
+ makedepends = cups
+ makedepends = libusb
+ depends = ghostscript>=8.64-6
+ optdepends = cups: for printing support
+ optdepends = libusb: for advanced usb support
+ conflicts = hplip
+ options = !docs
+ source = http://downloads.sourceforge.net/hplip/hplip-3.15.4.tar.gz
+ md5sums = 2cc12f3c8c2cf023891980c8a6b3fa5d
+
+pkgname = hplip-minimal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66b3ca68d1b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: megadriver <megadriver at gmx dot com>
+# Based on hplip from [extra]
+
+pkgname=hplip-minimal
+pkgver=3.15.4
+pkgrel=1
+pkgdesc="The HP printer drivers, and not much else"
+arch=('i686' 'x86_64' 'armv6h')
+url="http://hplipopensource.com"
+license=('GPL')
+depends=('ghostscript>=8.64-6')
+makedepends=('cups' 'libusb')
+optdepends=('cups: for printing support' 'libusb: for advanced usb support')
+conflicts=('hplip')
+options=('!docs')
+source=("http://downloads.sourceforge.net/hplip/hplip-$pkgver.tar.gz")
+md5sums=('2cc12f3c8c2cf023891980c8a6b3fa5d')
+
+prepare() {
+ cd "$srcdir/hplip-$pkgver"
+
+ # https://bugs.archlinux.org/task/30085 - hack found in Gentoo
+ # Use system foomatic-rip for hpijs driver instead of foomatic-rip-hplip
+ # The hpcups driver does not use foomatic-rip
+ local i
+ for i in ppd/hpijs/*.ppd.gz ; do
+ rm -f ${i}.temp
+ gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | gzip > ${i}.temp || return 1
+ mv ${i}.temp ${i}
+ done
+
+ export AUTOMAKE='automake --foreign'
+ autoreconf --force --install
+}
+
+build() {
+ cd "$srcdir/hplip-$pkgver"
+
+ ./configure --prefix=/usr --disable-qt4 --disable-doc-build --disable-dbus-build --disable-network-build \
+ --disable-scan-build --disable-fax-build --disable-foomatic-rip-hplip-install \
+ --enable-foomatic-ppd-install --enable-hpcups-only-build --enable-new-hpcups \
+ --disable-cups-drv-install --enable-cups-ppd-install --enable-pp-build
+ make
+}
+
+package() {
+ cd "$srcdir/hplip-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ # remove config provided by sane and autostart of hp-daemon
+ rm -rf "$pkgdir"/etc/{sane.d,xdg}
+
+ # remove HAL .fdi file because HAL is no longer used
+ rm -rf "$pkgdir"/usr/share/hal
+
+ # remove rc script
+ rm -rf "$pkgdir"/etc/init.d
+}