summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandmars2016-03-23 19:12:57 +0100
committerandmars2016-03-23 19:12:57 +0100
commitdf90c7962f007ed9bac499a04158c46d4919193e (patch)
tree0938f5270c7058d277b711a57bc542d80dcb467f
parent28682feaf3960a0d1cfdd25d64c46403f81bcf3b (diff)
downloadaur-df90c7962f007ed9bac499a04158c46d4919193e.tar.gz
Update to 3.16.3
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD55
2 files changed, 28 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ed05afe0853..38f72d16321c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = hplip-plugin
pkgdesc = Binary plugin for HPs hplip printer driver library
pkgver = 3.16.3
- pkgrel = 1
+ pkgrel = 2
url = http://hplipopensource.com/node/309
arch = i686
arch = x86_64
+ arch = armv7h
license = custom:proprietary
depends = hplip>=3.16.3
backup = var/lib/hp/hplip.state
diff --git a/PKGBUILD b/PKGBUILD
index a34e2db6e98d..c7069d341c07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: andmars < andreas.marschall @ unitybox.de >
# Contributor: PyroPeter < googlemail.com @ abi1789 >
+# Contributor: Ivan Shapovalov <intelfx@intelfx.name>
pkgname=hplip-plugin
pkgver=3.16.3
-pkgrel=1
+pkgrel=2
pkgdesc="Binary plugin for HPs hplip printer driver library"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h')
url="http://hplipopensource.com/node/309"
license=('custom:proprietary')
depends=("hplip>=$pkgver")
@@ -15,39 +16,36 @@ source=("http://hplipopensource.com/hplip-web/plugin/hplip-$pkgver-plugin.run")
md5sums=('504eacfacf8ff8d81365a7c4fd3ba00b')
prepare() {
- sh hplip-$pkgver-plugin.run --target "$srcdir/hplip-$pkgver-plugin" --noexec
-}
-
-build(){
- # Untargziping the makeself selfextracting archive
- cd $srcdir
- sh hplip-$pkgver-plugin.run --tar xvf
+ sh "hplip-$pkgver-plugin.run" --target "$srcdir/hplip-$pkgver-plugin" --noexec
}
package(){
+ cd "$srcdir/hplip-$pkgver-plugin"
+
if [ $CARCH = "i686" ]; then
_arch='x86_32'
elif [ $CARCH = "x86_64" ]; then
_arch='x86_64'
+ elif [ $CARCH = "armv7h" ]; then
+ _arch='arm32'
fi
# Create folders
- install -d $pkgdir/usr/share/hplip/data/firmware
- install -d $pkgdir/usr/share/hplip/fax/plugins
- install -d $pkgdir/usr/share/hplip/prnt/plugins
- install -d $pkgdir/usr/share/hplip/scan/plugins
- install -d $pkgdir/usr/share/licenses/hplip-plugin
- install -d $pkgdir/var/lib/hp
+ install -d "$pkgdir/usr/share/hplip/data/firmware"
+ install -d "$pkgdir/usr/share/hplip/fax/plugins"
+ install -d "$pkgdir/usr/share/hplip/prnt/plugins"
+ install -d "$pkgdir/usr/share/hplip/scan/plugins"
+ install -d "$pkgdir/usr/share/licenses/hplip-plugin"
+ install -d "$pkgdir/var/lib/hp"
# Copy files
- cd $srcdir
- install -m644 plugin.spec $pkgdir/usr/share/hplip/
- install -m644 hp_laserjet_*.fw.gz $pkgdir/usr/share/hplip/data/firmware/
- install -m755 fax_marvell-"$_arch".so $pkgdir/usr/share/hplip/fax/plugins/
- install -m755 hbpl1-"$_arch".so $pkgdir/usr/share/hplip/prnt/plugins/
- install -m755 lj-"$_arch".so $pkgdir/usr/share/hplip/prnt/plugins/
- install -m755 bb_*-"$_arch".so $pkgdir/usr/share/hplip/scan/plugins/
- install -m644 license.txt $pkgdir/usr/share/licenses/hplip-plugin/
+ install -m644 plugin.spec "$pkgdir/usr/share/hplip/"
+ install -m644 hp_laserjet_*.fw.gz "$pkgdir/usr/share/hplip/data/firmware/"
+ install -m755 fax_marvell-"$_arch".so "$pkgdir/usr/share/hplip/fax/plugins/"
+ install -m755 hbpl1-"$_arch".so "$pkgdir/usr/share/hplip/prnt/plugins/"
+ install -m755 lj-"$_arch".so "$pkgdir/usr/share/hplip/prnt/plugins/"
+ install -m755 bb_*-"$_arch".so "$pkgdir/usr/share/hplip/scan/plugins/"
+ install -m644 license.txt "$pkgdir/usr/share/licenses/hplip-plugin/"
# Create hplip.state used by hplip-tools
cat << EOF > hplip.state
@@ -56,14 +54,13 @@ installed = 1
eula = 1
version = $pkgver
EOF
- install -m644 hplip.state $pkgdir/var/lib/hp
+ install -m644 hplip.state "$pkgdir/var/lib/hp"
# Create symlinks
- for f in $(find $pkgdir/usr/share/hplip -type f -name "*.so"); do
- cd $pkgdir/usr/share/hplip
- cd $(dirname $f)
- link_name="$(basename $f | cut -d- -f1).so"
- ln -s $(basename $f) $link_name
+ find "$pkgdir/usr/share/hplip" -type f -name "*.so" | while read f; do
+ lib_dir="${f%/*}"
+ lib_name="${f##*/}"
+ ln -vsf "$lib_name" "$lib_dir/${lib_name%%-*}.so"
done
}