summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Nielsen2017-07-01 09:41:52 +1000
committerAdam Nielsen2017-07-01 09:41:52 +1000
commit1485282982a5e2e228aa150ebee4164147b3c218 (patch)
treea8ff79bddf6ff27ca4b940f63b2bd10f4adec92f
parent3432c9be616fe4be357d3adaa4147ff3e0ec3237 (diff)
downloadaur-1485282982a5e2e228aa150ebee4164147b3c218.tar.gz
Use architecture-specific source arrays and depend on ncurses5-compat
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
-rw-r--r--launcher.sh7
3 files changed, 19 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dcc9f5b55ee..3523e6674a45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
# Generated by mksrcinfo v8
-# Wed Jun 28 09:20:44 UTC 2017
+# Fri Jun 30 23:36:40 UTC 2017
pkgbase = hpltt
pkgdesc = HP Library & Tape Tools - diagnostics for HP tape drives
pkgver = 4.22
- pkgrel = 2
+ pkgrel = 3
url = https://www.hpe.com/us/en/product-catalog/storage/storage-software/pip.406729.html
arch = i686
arch = x86_64
license = custom:HPLTT
makedepends = libarchive
- depends = ncurses
+ depends = ncurses5-compat-libs
options = !strip
- source = launcher.sh
- md5sums = 4fe63395dbf71d288ab459e51dcbbb80
- sha256sums = 43a933ec34df64ed10fd6ea901fd57145811dcc5593920a5d4a5c4be2f90b678
+ source_i686 = ftp://ftp.hp.com/pub/softlib/software13/COL21415/co-170909-1/hpe_ltt422_linux_x86.tar
+ md5sums_i686 = d1a03385f9ee94c9b6f36a37dae7cadb
+ sha256sums_i686 = b72727911bc146e2951a2793607ae2a859045690b38d11de0457af0bbbce587f
+ source_x86_64 = ftp://ftp.hp.com/pub/softlib/software13/COL21415/co-170907-1/hpe_ltt422_linux_x86_64.tar
+ md5sums_x86_64 = 92e82d741b893b24a84eb40c2c2922a1
+ sha256sums_x86_64 = 486390e230a0d04d0514975c3da24cae6404882e021f589f68a22709c61c72f9
pkgname = hpltt
diff --git a/PKGBUILD b/PKGBUILD
index f55fdd968bbf..2d5e90e6d488 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,43 +7,30 @@
pkgname=hpltt
pkgver=4.22
-pkgrel=2
+pkgrel=3
pkgdesc="HP Library & Tape Tools - diagnostics for HP tape drives"
arch=('i686' 'x86_64')
url="https://www.hpe.com/us/en/product-catalog/storage/storage-software/pip.406729.html"
license=('custom:HPLTT')
makedepends=('libarchive')
-depends=('ncurses')
+depends=('ncurses5-compat-libs')
options=(!strip)
-# These are the only files we want to include in the source package
-source=(launcher.sh)
-md5sums=('4fe63395dbf71d288ab459e51dcbbb80')
-sha256sums=('43a933ec34df64ed10fd6ea901fd57145811dcc5593920a5d4a5c4be2f90b678')
+source_i686=('ftp://ftp.hp.com/pub/softlib/software13/COL21415/co-170909-1/hpe_ltt422_linux_x86.tar')
+md5sums_i686=('d1a03385f9ee94c9b6f36a37dae7cadb')
+sha256sums_i686=('b72727911bc146e2951a2793607ae2a859045690b38d11de0457af0bbbce587f')
-# Add the main file, depending on which architecture we're building for
-case "$CARCH" in
- i686)
- source[1]="ftp://ftp.hp.com/pub/softlib/software13/COL21415/co-170909-1/hpe_ltt422_linux_x86.tar"
- md5sums[1]='d1a03385f9ee94c9b6f36a37dae7cadb'
- sha256sums[1]='b72727911bc146e2951a2793607ae2a859045690b38d11de0457af0bbbce587f'
- ;;
- x86_64)
- source[1]="ftp://ftp.hp.com/pub/softlib/software13/COL21415/co-170907-1/hpe_ltt422_linux_x86_64.tar"
- md5sums[1]='92e82d741b893b24a84eb40c2c2922a1'
- sha256sums[1]='486390e230a0d04d0514975c3da24cae6404882e021f589f68a22709c61c72f9'
- ;;
-esac
+source_x86_64=('ftp://ftp.hp.com/pub/softlib/software13/COL21415/co-170907-1/hpe_ltt422_linux_x86_64.tar')
+md5sums_x86_64=('92e82d741b893b24a84eb40c2c2922a1')
+sha256sums_x86_64=('486390e230a0d04d0514975c3da24cae6404882e021f589f68a22709c61c72f9')
package() {
bsdtar -x -f ltt-*.rpm || (error "Multiple .rpm files in source folder, please clean remnants from earlier build (delete $srcdir and use makepkg -c in future)" ; exit 1)
mv opt "$pkgdir/"
- ln -s "/usr/lib/libncursesw.so.6" "$pkgdir/opt/ltt/libncurses.so.5"
install -d "$pkgdir/usr/bin"
- # Custom launch script to work with older ncurses library
- cp launcher.sh "$pkgdir/usr/bin/hpe_ltt"
- chmod 755 "$pkgdir/usr/bin/hpe_ltt"
+ # Put a symlink in /usr/bin for ease of launch
+ ln -s "/opt/ltt/hpe_ltt" "$pkgdir/usr/bin/hpe_ltt"
# Don't know why any dirs need to be world-writable when the app runs as root
# anyway, let's fix
diff --git a/launcher.sh b/launcher.sh
deleted file mode 100644
index 7ed3770930d6..000000000000
--- a/launcher.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-# Installation dir
-LTT='/opt/ltt'
-
-# Load libraries from installation dir first before looking in standard path
-LD_LIBRARY_PATH="$LTT" "$LTT/hpe_ltt"