summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-01-04 13:48:25 +0100
committerbartus2021-01-04 13:48:25 +0100
commitcceb5335af1eef630993a0189f3dcca5d319f3a5 (patch)
tree2bbdc51787cfa5fba9c4312f5d0fe0acf20d4c9c
parentce93d2acffbb15f2d933763bed9e79f12c89b5e0 (diff)
downloadaur-cceb5335af1eef630993a0189f3dcca5d319f3a5.tar.gz
Strip nlop internal dep.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--external_nlopt.patch38
3 files changed, 60 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94b5c10375e3..e6a9337e12b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hpmvs-git
pkgdesc = Progressive multiview stero, generate dense surface form sparse 3D model.
pkgver = r18.f003e54
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/alexlocher/hpmvs
arch = i686
arch = x86_64
@@ -13,10 +13,16 @@ pkgbase = hpmvs-git
depends = libjpeg
depends = google-glog
depends = gflags
+ depends = nlopt>=2.4.2
source = hpmvs-git::git+https://github.com/alexlocher/hpmvs.git
source = https://openaccess.thecvf.com/content_cvpr_2016/papers/Locher_Progressive_Prioritized_Multi-View_CVPR_2016_paper.pdf
- md5sums = SKIP
- md5sums = f5a13b2ac11fda01a29e90f93893b94d
+ source = external_nlopt.patch
+ sha256sums = SKIP
+ sha256sums = 3c760202058a0bc78d12b53ed535c94b2d5e44765c0b1b15208fb7dcee935df3
+ sha256sums = 3067ac77cb8d5fcb9bd7871918701325b5e51b731c929e52966bf988a52ee06b
+ b2sums = SKIP
+ b2sums = e630f1f418264d8a4a93b8ff72e4751e777b8a6094f53b0b1477e4a048b2cf9024f45c138047a6635509e63e38d6b2b291eb9e16f00b58ef3bcb4795fd6258fd
+ b2sums = 3f551f68ec7905e7e07331c540b7c4dac14fcdbb42290401b89624fa37725f0043881561986e16ebc37dcfed6838236c3cb7903bdab4736ebe4151fda531a0cf
pkgname = hpmvs-git
diff --git a/PKGBUILD b/PKGBUILD
index 7d89f27a69b2..9724d336cda0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,36 @@
name=hpmvs
pkgname=${name}-git
pkgver=r18.f003e54
-pkgrel=2
+pkgrel=3
pkgdesc="Progressive multiview stero, generate dense surface form sparse 3D model."
arch=('i686' 'x86_64')
url="https://github.com/alexlocher/hpmvs"
license=('GPL')
groups=()
-depends=('libjpeg' 'google-glog' 'gflags')
+depends=('libjpeg' 'google-glog' 'gflags' 'nlopt>=2.4.2')
makedepends=('git' 'cmake' 'eigen' 'ninja')
provides=()
options=()
source=("${pkgname}::git+https://github.com/alexlocher/hpmvs.git"
"https://openaccess.thecvf.com/content_cvpr_2016/papers/Locher_Progressive_Prioritized_Multi-View_CVPR_2016_paper.pdf"
+ "external_nlopt.patch"
)
-md5sums=('SKIP'
- 'f5a13b2ac11fda01a29e90f93893b94d')
+sha256sums=('SKIP'
+ '3c760202058a0bc78d12b53ed535c94b2d5e44765c0b1b15208fb7dcee935df3'
+ '3067ac77cb8d5fcb9bd7871918701325b5e51b731c929e52966bf988a52ee06b')
+b2sums=('SKIP'
+ 'e630f1f418264d8a4a93b8ff72e4751e777b8a6094f53b0b1477e4a048b2cf9024f45c138047a6635509e63e38d6b2b291eb9e16f00b58ef3bcb4795fd6258fd'
+ '3f551f68ec7905e7e07331c540b7c4dac14fcdbb42290401b89624fa37725f0043881561986e16ebc37dcfed6838236c3cb7903bdab4736ebe4151fda531a0cf')
pkgver() {
cd "${srcdir}/${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ git -C "$srcdir/$pkgname" apply -v "$srcdir"/external_nlopt.patch
+}
+
build() {
cmake -DBUILD_SHARED_LIBS=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -S ${pkgname} -B build -G Ninja
# shellcheck disable=SC2086 # allow expanding MAKEFLAGS
diff --git a/external_nlopt.patch b/external_nlopt.patch
new file mode 100644
index 000000000000..f3ec5c20d9d2
--- /dev/null
+++ b/external_nlopt.patch
@@ -0,0 +1,38 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f6cb247..5a89f65 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,7 +15,6 @@ find_package(Gflags REQUIRED)
+ add_definitions(-DHPMVS_GFLAGS_NAMESPACE=${GFLAGS_NAMESPACE})
+ find_package(Glog REQUIRED)
+
+-ADD_SUBDIRECTORY(thirdLibs/nlopt-2.4.2)
+ ADD_SUBDIRECTORY(thirdLibs/stlplus3)
+
+ set(HPMVS_SRC
+@@ -42,7 +41,7 @@ set(HPMVS_INCLUDE_DIRS
+ ${JPEG_INCLUDE_DIR}
+ ${GFLAGS_INCLUDE_DIRS}
+ ${GLOG_INCLUDE_DIRS}
+- ${PROJECT_SOURCE_DIR}/thirdLibs/nlopt-2.4.2/api
++ /usr/include
+ ${PROJECT_SOURCE_DIR}/thirdLibs/cimg
+ ${PROJECT_SOURCE_DIR}/thirdLibs/
+ ${PROJECT_SOURCE_DIR}/thirdLibs/stlplus3
+@@ -55,7 +54,6 @@ set(HPMVS_LIBRARIES
+ ${JPEG_LIBRARIES}
+ ${GFLAGS_LIBRARIES}
+ ${GLOG_LIBRARIES}
+- nlopt
+ stlplus3_hpmvs
+ )
+
+@@ -67,7 +65,7 @@ target_link_libraries(HPMVS_static ${HPMVS_LIBRARIES})
+
+ # build the executable
+ add_executable (hpmvs src/main.cpp)
+-target_link_libraries(hpmvs HPMVS_static ${HPMVS_LIBRARIES})
++target_link_libraries(hpmvs HPMVS_static ${HPMVS_LIBRARIES} nlopt)
+
+ # install path
+ install(TARGETS hpmvs RUNTIME DESTINATION bin)