summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2019-10-09 09:41:59 +0200
committerGuilhem Saurel2019-10-09 09:41:59 +0200
commit05736da07a594d622854ce1808d6f86957980aa0 (patch)
tree2c89b1b342928e2ba7691bc9359061887cfd4931
parentcd0fdc638fa117f6e5e12403e6206f44042a1f14 (diff)
downloadaur-05736da07a594d622854ce1808d6f86957980aa0.tar.gz
fix octomap detection
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fdc132dda9e..8d353e326ce6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hpp-fcl
pkgdesc = An extension of the Flexible Collision Library
pkgver = 1.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/humanoid-path-planner/hpp-fcl
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index cc479aaf836f..e26e080f3114 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgorg='humanoid-path-planner'
pkgname=('hpp-fcl' 'hpp-fcl-docs')
pkgver=1.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="An extension of the Flexible Collision Library"
arch=('i686' 'x86_64')
url="https://github.com/$pkgorg/$pkgname"
@@ -18,6 +18,8 @@ validpgpkeys=('9B1A79065D2F2B806C8A5A1C7D2ACDAF4653CF28' 'A031AD35058955293D54DE
build() {
cd "$pkgbase-$pkgver"
+ sed -i 's/OCTOMAP_INCLUDE_DIRS AND OCTOMAP_LIBRARY_DIRS/OCTOMAP_FOUND/' CMakeLists.txt
+
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib .
make
}