summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2019-05-02 09:41:33 +0200
committerGuilhem Saurel2019-05-02 09:41:33 +0200
commit22e6d15c571c7bc3c728084b524b41c0e37fd90c (patch)
treee9bf16b753cdc23deaf4e32ec761a9f89bc24397
parent1882d183ac659f9ad844620602616100f3a0ae0c (diff)
downloadaur-22e6d15c571c7bc3c728084b524b41c0e37fd90c.tar.gz
update to v1.0.2, use PGP, install license, fix depends
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
3 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71b0e117d68f..9028fd199394 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = hpp-fcl
pkgdesc = An extension of the Flexible Collision Library
- pkgver = 0.6.0
+ pkgver = 1.0.2
pkgrel = 1
url = https://github.com/humanoid-path-planner/hpp-fcl
arch = i686
arch = x86_64
- license = BSD 3-clause
+ license = BSD
makedepends = cmake
- depends = eigen
depends = assimp
- source = http://www.openrobots.org/distfiles/hpp-fcl/hpp-fcl-0.6.0.tar.gz
- md5sums = 95f189b2d79154c9fa76ba8bc3edb109
+ optdepends = doxygen
+ optdepends = octomap
+ source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v1.0.2/hpp-fcl-1.0.2.tar.gz
+ source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v1.0.2/hpp-fcl-1.0.2.tar.gz.sig
+ validpgpkeys = 9B1A79065D2F2B806C8A5A1C7D2ACDAF4653CF28
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = hpp-fcl
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e2db7e54264b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+hpp-fcl*
diff --git a/PKGBUILD b/PKGBUILD
index 8fb0ad2d5afc..a95432617659 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# Maintainer: Guilhem Saurel <saurel@laas.fr>
pkgname=hpp-fcl
-pkgver=0.6.0
+pkgver=1.0.2
pkgrel=1
pkgdesc="An extension of the Flexible Collision Library"
arch=('i686' 'x86_64')
url="https://github.com/humanoid-path-planner/$pkgname"
-license=('BSD 3-clause')
-depends=('eigen' 'assimp')
+license=('BSD')
+depends=('assimp')
+optdepends=('doxygen' 'octomap')
+makedepends=('eigen')
makedepends=('cmake')
-source=("http://www.openrobots.org/distfiles/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('95f189b2d79154c9fa76ba8bc3edb109')
+source=($url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz{,.sig})
+md5sums=('SKIP' 'SKIP')
+validpgpkeys=('9B1A79065D2F2B806C8A5A1C7D2ACDAF4653CF28')
build() {
cd "$pkgname-$pkgver"
+
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib .
make
}
@@ -21,4 +25,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}