summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2017-03-27 18:30:14 +0200
committerGuilhem Saurel2017-03-27 18:30:14 +0200
commit49bf5851b0a2af952c12cc8570001274a2f19a19 (patch)
tree9d419ea6181d4462c37fa51f069b6596f5ed1fad
downloadaur-49bf5851b0a2af952c12cc8570001274a2f19a19.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2d695d946c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hpp-fcl
+ pkgdesc = An extension of the Flexible Collision Library
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://github.com/humanoid-path-planner/hpp-fcl
+ arch = i686
+ arch = x86_64
+ license = BSD 3-clause
+ makedepends = cmake
+ makedepends = pkg-config
+ depends = eigen32
+ source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v0.5/hpp-fcl-0.5.tar.gz
+ md5sums = e872800a18086367ff3eb18a5beae6a4
+
+pkgname = hpp-fcl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60b651fcb6f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guilhem Saurel <saurel@laas.fr>
+
+pkgname=hpp-fcl
+pkgver=0.5
+pkgrel=1
+pkgdesc="An extension of the Flexible Collision Library"
+arch=('i686' 'x86_64')
+url="https://github.com/humanoid-path-planner/hpp-fcl"
+license=('BSD 3-clause')
+depends=('eigen32')
+optdepends=()
+makedepends=('cmake' 'pkg-config')
+conflicts=()
+source=("https://github.com/humanoid-path-planner/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('e872800a18086367ff3eb18a5beae6a4')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib .
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}