summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2019-12-17 18:20:29 +0100
committerGuilhem Saurel2019-12-17 18:20:29 +0100
commit4f6f0f34a3bbb998a668fe5e2263182bc23c1dc1 (patch)
treeb2eb07896c2a528fb3c1a37c3cbff1fb8a77e76d
parent57a79db08ed5604f70ec1145a7ae5817461873f3 (diff)
downloadaur-4f6f0f34a3bbb998a668fe5e2263182bc23c1dc1.tar.gz
v1.2.2 & Python bindings
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13877df1aaa9..86e928ca6cd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hpp-fcl
pkgdesc = An extension of the Flexible Collision Library
- pkgver = 1.2.0
+ pkgver = 1.2.2
pkgrel = 1
url = https://github.com/humanoid-path-planner/hpp-fcl
arch = i686
@@ -9,10 +9,11 @@ pkgbase = hpp-fcl
makedepends = cmake
makedepends = eigen
depends = assimp
+ depends = eigenpy
optdepends = doxygen
optdepends = octomap
- source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v1.2.0/hpp-fcl-1.2.0.tar.gz
- source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v1.2.0/hpp-fcl-1.2.0.tar.gz.sig
+ source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v1.2.2/hpp-fcl-1.2.2.tar.gz
+ source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v1.2.2/hpp-fcl-1.2.2.tar.gz.sig
validpgpkeys = 9B1A79065D2F2B806C8A5A1C7D2ACDAF4653CF28
validpgpkeys = A031AD35058955293D54DECEC45D22EF408328AD
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 81d9a6ab3f8e..9f57940127fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgorg='humanoid-path-planner'
pkgname=('hpp-fcl' 'hpp-fcl-docs')
-pkgver=1.2.0
+pkgver=1.2.2
pkgrel=1
pkgdesc="An extension of the Flexible Collision Library"
arch=('i686' 'x86_64')
url="https://github.com/$pkgorg/$pkgname"
license=('BSD')
-depends=('assimp')
+depends=('assimp' 'eigenpy')
optdepends=('doxygen' 'octomap')
makedepends=('cmake' 'eigen')
source=($url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz{,.sig})
@@ -18,7 +18,8 @@ validpgpkeys=('9B1A79065D2F2B806C8A5A1C7D2ACDAF4653CF28' 'A031AD35058955293D54DE
build() {
cd "$pkgbase-$pkgver"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib .
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_PYTHON_INTERFACE=ON .
make
}