summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2024-01-23 19:26:33 +0100
committerGuilhem Saurel2024-01-23 19:26:33 +0100
commit692dc4c4c99f83a515c5c2b03627d54a50e6f590 (patch)
treebfe9b619293f79acaff13c801d74190f37b6af65
parentbb3e30614428e8db23f84802b22dfefdd9b88c8e (diff)
downloadaur-692dc4c4c99f83a515c5c2b03627d54a50e6f590.tar.gz
v2.4.1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 35 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fa9a59a0c78..8009f9532d90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,32 @@
pkgbase = hpp-fcl
pkgdesc = An extension of the Flexible Collision Library
- pkgver = 2.4.0
- pkgrel = 1
+ pkgver = 2.4.1
+ pkgrel = 2
url = https://github.com/humanoid-path-planner/hpp-fcl
arch = i686
arch = x86_64
- license = BSD
+ license = BSD-2-Clause
makedepends = cmake
- makedepends = eigen
makedepends = boost
depends = assimp
+ depends = eigen
depends = eigenpy
depends = octomap
depends = qhull
depends = python-numpy
+ depends = boost-libs
+ depends = python
+ depends = glibc
+ depends = gcc-libs
optdepends = doxygen
- source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v2.4.0/hpp-fcl-2.4.0.tar.gz
- source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v2.4.0/hpp-fcl-2.4.0.tar.gz.sig
+ source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v2.4.1/hpp-fcl-2.4.1.tar.gz
+ source = https://github.com/humanoid-path-planner/hpp-fcl/releases/download/v2.4.1/hpp-fcl-2.4.1.tar.gz.sig
validpgpkeys = 9B1A79065D2F2B806C8A5A1C7D2ACDAF4653CF28
validpgpkeys = A031AD35058955293D54DECEC45D22EF408328AD
validpgpkeys = 1462AF00C9CF3C9E7AFC905E63380359F089A579
- sha256sums = 15b5f1d6fe98fd3bf175913821296c14b31ce1822ef303d9c6dff8ad2fefc733
+ sha256sums = b6561bd76c0f5ca7a57c1e607cbcac31c8063fe58b9b42f229ae1e9e3cfa6ed9
sha256sums = SKIP
pkgname = hpp-fcl
+
+pkgname = hpp-fcl-docs
diff --git a/PKGBUILD b/PKGBUILD
index d1f319711313..8f22ae753f09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: Guilhem Saurel <saurel@laas.fr>
-pkgorg='humanoid-path-planner'
+_org='humanoid-path-planner'
_pkgname='hpp-fcl'
-#pkgname=("$_pkgname" "$_pkgname-docs")
-pkgname=("$_pkgname")
-pkgver=2.4.0
-pkgrel=1
+pkgname=("$_pkgname" "$_pkgname-docs")
+pkgver=2.4.1
+pkgrel=2
pkgdesc="An extension of the Flexible Collision Library"
arch=('i686' 'x86_64')
-url="https://github.com/$pkgorg/$pkgname"
-license=('BSD')
-depends=('assimp' 'eigenpy' 'octomap' 'qhull' 'python-numpy')
+url="https://github.com/$_org/$_pkgname"
+license=('BSD-2-Clause')
+depends=('assimp' 'eigen' 'eigenpy' 'octomap' 'qhull' 'python-numpy' 'boost-libs' 'python' 'glibc' 'gcc-libs')
optdepends=('doxygen')
-makedepends=('cmake' 'eigen' 'boost')
-source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"{,.sig})
-sha256sums=('15b5f1d6fe98fd3bf175913821296c14b31ce1822ef303d9c6dff8ad2fefc733'
+makedepends=('cmake' 'boost')
+source=("$url/releases/download/v$pkgver/$_pkgname-$pkgver.tar.gz"{,.sig})
+sha256sums=('b6561bd76c0f5ca7a57c1e607cbcac31c8063fe58b9b42f229ae1e9e3cfa6ed9'
'SKIP')
validpgpkeys=(
'9B1A79065D2F2B806C8A5A1C7D2ACDAF4653CF28' # https://github.com/nim65s.gpg
@@ -28,10 +27,10 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_PREFIX=/usr \
-DGENERATE_PYTHON_STUBS=ON \
- -DINSTALL_DOCUMENTATION=OFF \
- -DBUILD_DOCUMENTATION=OFF \
+ -DINSTALL_DOCUMENTATION=ON \
+ -DBUILD_DOCUMENTATION=ON \
-Wno-dev
- cmake --build "build-$pkgver"
+ cmake --build "build-$pkgver"
}
check() {
@@ -40,14 +39,14 @@ check() {
package_hpp-fcl() {
DESTDIR="$pkgdir/" cmake --build "build-$pkgver" -t install
- rm -rf "$pkgdir/usr/share/doc"
- sed -i 's=;/usr/\.\./include/include==' "$pkgdir/usr/lib/cmake/hpp-fcl/hpp-fclTargets.cmake"
- sed -i '/Boost COMPONENTS/s/python3//' "$pkgdir/usr/lib/cmake/hpp-fcl/hpp-fclConfig.cmake"
- install -Dm644 "$pkgbase-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rm -rf "$pkgdir/usr/share/doc"
+ sed -i 's=;/usr/\.\./include/include==' "$pkgdir/usr/lib/cmake/hpp-fcl/hpp-fclTargets.cmake"
+ sed -i '/Boost COMPONENTS/s/python3//' "$pkgdir/usr/lib/cmake/hpp-fcl/hpp-fclConfig.cmake"
+ install -Dm644 "$pkgbase-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-#package_hpp-fcl-docs() {
-#DESTDIR="$pkgdir/" cmake --build "build-$pkgver" -t install
-#rm -rf "$pkgdir"/usr/{lib,include,share/{"$_pkgname",ament_index}}
-#install -Dm644 "$pkgbase-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-#}
+package_hpp-fcl-docs() {
+ DESTDIR="$pkgdir/" cmake --build "build-$pkgver" -t install
+ rm -rf "$pkgdir"/usr/{lib,include,share/{"$_pkgname",ament_index}}
+ install -Dm644 "$pkgbase-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}