summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2024-01-10 14:01:08 +0100
committerGuilhem Saurel2024-01-10 14:02:21 +0100
commit6a9ecfdf6e9716db1aa8a8d187fdf7460e95c600 (patch)
tree33d6a249817d7269312038545cfa3f7b6a9fbfff
parentccf76a94c7349c91cdedaa5b4ad7bcbf76774d0d (diff)
downloadaur-6a9ecfdf6e9716db1aa8a8d187fdf7460e95c600.tar.gz
update
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD56
3 files changed, 56 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b1afdc7f8e5..5a1c32375dac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,28 @@
pkgbase = hpp-fcl-git
pkgdesc = An extension of the Flexible Collision Library
- pkgver = 0.5.r538.5641ae1
- pkgrel = 2
- url = https://github.com/humanoid-path-planner/hpp-fcl-git
+ pkgver = 2.4.0.r2280.6981036f
+ pkgrel = 1
+ url = https://github.com/humanoid-path-planner/hpp-fcl
arch = i686
arch = x86_64
- license = BSD 3-clause
+ license = BSD
makedepends = cmake
- depends = eigen
+ makedepends = eigen
+ makedepends = boost
+ makedepends = git
depends = assimp
+ depends = eigenpy
+ depends = octomap
+ depends = qhull
+ depends = python-numpy
+ depends = boost-libs
+ optdepends = doxygen
provides = hpp-fcl
conflicts = hpp-fcl
- source = hpp-fcl::git://github.com/nim65s/hpp-fcl.git
- md5sums = SKIP
+ source = git+https://github.com/humanoid-path-planner/hpp-fcl#branch=fetch-submodule
+ sha256sums = SKIP
pkgname = hpp-fcl-git
+pkgname = hpp-fcl-git-docs
+
diff --git a/.gitignore b/.gitignore
index 7ff2a203d436..4c4aa4df41e4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
hpp-fcl
src
pkg
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index c15903883788..cf0a7c961d36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Guilhem Saurel <saurel@laas.fr>
-_pkgname=hpp-fcl
-_pkgver=0.5
-pkgname=${_pkgname}-git
-pkgver=0.5.r538.5641ae1
-pkgrel=2
+_org='humanoid-path-planner'
+_pkgname='hpp-fcl'
+_pkgver=2.4.0
+pkgname=("${_pkgname}-git" "${_pkgname}-git-docs")
+pkgver=2.4.0.r2280.6981036f
+pkgrel=1
pkgdesc="An extension of the Flexible Collision Library"
arch=('i686' 'x86_64')
-url="https://github.com/humanoid-path-planner/$pkgname"
-license=('BSD 3-clause')
-depends=('eigen' 'assimp')
-makedepends=('cmake')
+url="https://github.com/$_org/$_pkgname"
+license=('BSD')
+depends=('assimp' 'eigenpy' 'octomap' 'qhull' 'python-numpy' 'boost-libs')
+optdepends=('doxygen')
+makedepends=('cmake' 'eigen' 'boost' 'git')
conflicts=($_pkgname)
provides=($_pkgname)
-source=("$_pkgname"::"git://github.com/nim65s/$_pkgname.git")
-md5sums=('SKIP')
+source=("git+${url}#branch=fetch-submodule")
+sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
@@ -22,13 +24,31 @@ pkgver() {
}
build() {
- cd "$_pkgname"
- git submodule update --init
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib .
- make
+ cmake -B "build-git" -S "$_pkgname" \
+ -DHPP_FCL_HAS_QHULL=ON \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DGENERATE_PYTHON_STUBS=ON \
+ -DINSTALL_DOCUMENTATION=ON \
+ -DBUILD_DOCUMENTATION=ON \
+ -Wno-dev
+ cmake --build "build-git"
}
-package() {
- cd "$_pkgname"
- make DESTDIR="$pkgdir/" install
+check() {
+ cmake --build "build-git" -t test
+}
+
+package_hpp-fcl-git() {
+ DESTDIR="$pkgdir/" cmake --build "build-git" -t install
+ rm -rf "$pkgdir/usr/share/doc"
+ sed -i 's=;/usr/\.\./include/include==' "$pkgdir/usr/lib/cmake/hpp-fcl/hpp-fclTargets.cmake"
+ sed -i '/Boost COMPONENTS/s/python3//' "$pkgdir/usr/lib/cmake/hpp-fcl/hpp-fclConfig.cmake"
+ install -Dm644 "$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_hpp-fcl-git-docs() {
+ DESTDIR="$pkgdir/" cmake --build "build-git" -t install
+ rm -rf "$pkgdir"/usr/{lib,include,share/{"$_pkgname",ament_index}}
+ install -Dm644 "$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}