summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2024-01-10 22:49:14 +0100
committerGuilhem Saurel2024-01-10 22:49:14 +0100
commita4f2cf734abdc07d9d1022e2cba0ce9596a5ad1c (patch)
tree815001c9d4f3314df617ae59fd8359e927794499
parentd2001a49e91f8f39c41346a5e9f9843032f5c4bf (diff)
downloadaur-a4f2cf734abdc07d9d1022e2cba0ce9596a5ad1c.tar.gz
patch merged
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD23
3 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd6a02621ff1..ead0a71ce84b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hpp-fcl-git
pkgdesc = An extension of the Flexible Collision Library
- pkgver = 2.4.0.r2279.51f101c9
+ pkgver = 2.4.0.r2282.8bdad148
pkgrel = 1
url = https://github.com/humanoid-path-planner/hpp-fcl
arch = i686
@@ -10,20 +10,23 @@ pkgbase = hpp-fcl-git
makedepends = eigen
makedepends = boost
makedepends = git
+ makedepends = doxygen
depends = assimp
depends = eigenpy
depends = octomap
depends = qhull
depends = python-numpy
depends = boost-libs
- optdepends = doxygen
- provides = hpp-fcl
- conflicts = hpp-fcl
+ depends = gcc-libs
+ depends = glibc
+ depends = python
source = git+https://github.com/humanoid-path-planner/hpp-fcl
- source = https://github.com/humanoid-path-planner/hpp-fcl/pull/512.patch
sha256sums = SKIP
- sha256sums = 594fda5541090f5a1f2e27ad44751c491f338bab3fe98e7739eb4593977a2064
pkgname = hpp-fcl-git
+ provides = hpp-fcl
+ conflicts = hpp-fcl
pkgname = hpp-fcl-git-docs
+ provides = hpp-fcl-docs
+ conflicts = hpp-fcl-docs
diff --git a/.gitignore b/.gitignore
index 775fd7350bad..6c54dca3ea13 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@ hpp-fcl
src
pkg
*.zst
+*.sig
*.patch
diff --git a/PKGBUILD b/PKGBUILD
index c8497c79b413..e0c3a5c37265 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,22 @@ _org='humanoid-path-planner'
_pkgname='hpp-fcl'
_pkgver=2.4.0
pkgname=("${_pkgname}-git" "${_pkgname}-git-docs")
-pkgver=2.4.0.r2279.51f101c9
+pkgver=2.4.0.r2282.8bdad148
pkgrel=1
pkgdesc="An extension of the Flexible Collision Library"
arch=('i686' 'x86_64')
url="https://github.com/$_org/$_pkgname"
license=('BSD')
-depends=('assimp' 'eigenpy' 'octomap' 'qhull' 'python-numpy' 'boost-libs')
-optdepends=('doxygen')
-makedepends=('cmake' 'eigen' 'boost' 'git')
-conflicts=($_pkgname)
-provides=($_pkgname)
-source=("git+${url}" "$url/pull/512.patch")
-sha256sums=('SKIP'
- '594fda5541090f5a1f2e27ad44751c491f338bab3fe98e7739eb4593977a2064')
+depends=('assimp' 'eigenpy' 'octomap' 'qhull' 'python-numpy' 'boost-libs' 'gcc-libs' 'glibc' 'python')
+makedepends=('cmake' 'eigen' 'boost' 'git' 'doxygen')
+source=("git+${url}")
+sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
echo "$_pkgver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$_pkgname"
- patch -p1 -i "$srcdir/512.patch"
-}
-
build() {
cmake -B "build-git" -S "$_pkgname" \
-DHPP_FCL_HAS_QHULL=ON \
@@ -46,6 +37,8 @@ check() {
}
package_hpp-fcl-git() {
+ conflicts=("$_pkgname")
+ provides=("$_pkgname")
DESTDIR="$pkgdir/" cmake --build "build-git" -t install
rm -rf "$pkgdir/usr/share/doc"
sed -i 's=;/usr/\.\./include/include==' "$pkgdir/usr/lib/cmake/hpp-fcl/hpp-fclTargets.cmake"
@@ -54,6 +47,8 @@ package_hpp-fcl-git() {
}
package_hpp-fcl-git-docs() {
+ conflicts=("${_pkgname}-docs")
+ provides=("${_pkgname}-docs")
DESTDIR="$pkgdir/" cmake --build "build-git" -t install
rm -rf "$pkgdir"/usr/{lib,include,share/{"$_pkgname",ament_index}}
install -Dm644 "$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"