summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2024-01-10 14:09:11 +0100
committerGuilhem Saurel2024-01-10 14:09:11 +0100
commitd2001a49e91f8f39c41346a5e9f9843032f5c4bf (patch)
tree12a76c3046c74b0fe52392eb8b8c8168628bd69f
parent6a9ecfdf6e9716db1aa8a8d187fdf7460e95c600 (diff)
downloadaur-d2001a49e91f8f39c41346a5e9f9843032f5c4bf.tar.gz
patch
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
3 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a1c32375dac..cd6a02621ff1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hpp-fcl-git
pkgdesc = An extension of the Flexible Collision Library
- pkgver = 2.4.0.r2280.6981036f
+ pkgver = 2.4.0.r2279.51f101c9
pkgrel = 1
url = https://github.com/humanoid-path-planner/hpp-fcl
arch = i686
@@ -19,10 +19,11 @@ pkgbase = hpp-fcl-git
optdepends = doxygen
provides = hpp-fcl
conflicts = hpp-fcl
- source = git+https://github.com/humanoid-path-planner/hpp-fcl#branch=fetch-submodule
+ source = git+https://github.com/humanoid-path-planner/hpp-fcl
+ source = https://github.com/humanoid-path-planner/hpp-fcl/pull/512.patch
sha256sums = SKIP
+ sha256sums = 594fda5541090f5a1f2e27ad44751c491f338bab3fe98e7739eb4593977a2064
pkgname = hpp-fcl-git
pkgname = hpp-fcl-git-docs
-
diff --git a/.gitignore b/.gitignore
index 4c4aa4df41e4..775fd7350bad 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ hpp-fcl
src
pkg
*.zst
+*.patch
diff --git a/PKGBUILD b/PKGBUILD
index cf0a7c961d36..c8497c79b413 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _org='humanoid-path-planner'
_pkgname='hpp-fcl'
_pkgver=2.4.0
pkgname=("${_pkgname}-git" "${_pkgname}-git-docs")
-pkgver=2.4.0.r2280.6981036f
+pkgver=2.4.0.r2279.51f101c9
pkgrel=1
pkgdesc="An extension of the Flexible Collision Library"
arch=('i686' 'x86_64')
@@ -15,14 +15,20 @@ optdepends=('doxygen')
makedepends=('cmake' 'eigen' 'boost' 'git')
conflicts=($_pkgname)
provides=($_pkgname)
-source=("git+${url}#branch=fetch-submodule")
-sha256sums=('SKIP')
+source=("git+${url}" "$url/pull/512.patch")
+sha256sums=('SKIP'
+ '594fda5541090f5a1f2e27ad44751c491f338bab3fe98e7739eb4593977a2064')
pkgver() {
cd "$_pkgname"
echo "$_pkgver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$_pkgname"
+ patch -p1 -i "$srcdir/512.patch"
+}
+
build() {
cmake -B "build-git" -S "$_pkgname" \
-DHPP_FCL_HAS_QHULL=ON \