summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2017-04-03 23:21:13 +0200
committerGuilhem Saurel2017-04-03 23:21:13 +0200
commit07622b2fbc02ac4e9bc9e2b67561d37b7d965e50 (patch)
tree2f2f2a7c978edd4670f4284fb7337cc19e7563c9
downloadaur-07622b2fbc02ac4e9bc9e2b67561d37b7d965e50.tar.gz
first commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c3ed108fa1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = hpp-pinocchio-git
+ pkgdesc = Refactoring of hpp-model using the kinematic tree of pinocchio
+ pkgver = 4.0.1.
+ pkgrel = 1
+ url = https://github.com/humanoid-path-planner/hpp-pinocchio
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = doxygen
+ depends = boost
+ depends = pinocchio
+ provides = hpp-pinocchio
+ conflicts = hpp-pinocchio
+ source = hpp-pinocchio::git://github.com/humanoid-path-planner/hpp-pinocchio.git
+ md5sums = SKIP
+
+pkgname = hpp-pinocchio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..298e5c0c32cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Guilhem Saurel <saurel@laas.fr>
+
+_pkgname=hpp-pinocchio
+_pkgver=4.0.1
+_ros=ros-indigo
+pkgname=${_pkgname}-git
+pkgver=4.0.1.r177.338bb77
+pkgrel=1
+pkgdesc="Refactoring of hpp-model using the kinematic tree of pinocchio"
+arch=('i686' 'x86_64')
+url="https://github.com/humanoid-path-planner/$_pkgname"
+license=('LGPL3')
+depends=('boost' 'pinocchio' 'assimp' 'hpp-util' 'hpp-fcl' "$_ros-resource-retriever")
+optdepends=('hpp-model' 'hpp-model-urdf' 'romeo_description' 'hpp_environments')
+makedepends=('cmake' 'git' 'doxygen' 'ros-build-tools' "$_ros-catkin")
+conflicts=($_pkgname)
+provides=($_pkgname)
+source=("$_pkgname"::"git://github.com/humanoid-path-planner/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ echo "$_pkgver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+ git submodule update --init
+ git checkout devel
+}
+
+build() {
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ source /opt/ros/indigo/setup.bash
+ cd "$_pkgname"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib .
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}