summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHeine Pedersen2015-06-10 20:31:36 +0200
committerHeine Pedersen2015-06-10 20:31:36 +0200
commit8e8ca65c029d0502b12dd33f62c665d3e012c757 (patch)
treee257c6ce507208b567b1306d9e10bd527604adc6
downloadaur-8e8ca65c029d0502b12dd33f62c665d3e012c757.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
-rw-r--r--hptwebgui.install9
-rw-r--r--hptwebgui.service13
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50bbf5711ff4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hptwebgui
+ pkgdesc = WebGUI for HighPoint RocketRaid 2xxx/3xxx/4xxx RAID Controllers
+ pkgver = 2.1.5.130409
+ pkgrel = 2
+ url = http://www.highpoint-tech.com
+ install = hptwebgui.install
+ arch = x86_64
+ license = custom
+ makedepends = rpmextract
+ provides = hptwebgui
+ conflicts = hpt-cli
+ source = http://www.highpoint-tech.com/BIOS_Driver/HRM/Linux/WebGUI-Linux-v2.1.5-130409.tgz
+ source = hptwebgui.service
+ md5sums = e65216725b279e74d583768a989e2ee7
+ md5sums = 00c19d865b93cd635fbea78b32af7787
+
+pkgname = hptwebgui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddfac83c5b01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Heine Pedersen <heinep at gmail dot com>
+# Contributor: Thomas Matysik <thomas at matysik dot co dot nz>
+
+_realname=WebGUI-Linux
+_pkgver=2.1.5
+_pkgrelmajor=13
+_pkgrelminor=0409
+
+pkgname=hptwebgui
+pkgver=${_pkgver}.${_pkgrelmajor}${_pkgrelminor}
+pkgrel=2
+
+pkgdesc="WebGUI for HighPoint RocketRaid 2xxx/3xxx/4xxx RAID Controllers"
+arch=('x86_64')
+url="http://www.highpoint-tech.com"
+license=('custom')
+makedepends=('rpmextract')
+provides=('hptwebgui')
+conflicts=('hpt-cli')
+install=hptwebgui.install
+source=(http://www.highpoint-tech.com/BIOS_Driver/HRM/Linux/${_realname}-v${_pkgver}-${_pkgrelmajor}${_pkgrelminor}.tgz
+ hptwebgui.service)
+
+md5sums=('e65216725b279e74d583768a989e2ee7'
+ '00c19d865b93cd635fbea78b32af7787')
+
+package() {
+ rpmextract.sh "${srcdir}"/hptsvr-https-${_pkgver}-${_pkgrelmajor}.${_pkgrelminor}.${arch}.rpm
+ install -m755 -d "${pkgdir}/usr/bin"
+ install -m755 -d "${pkgdir}/usr/share/hpt"
+ install -m755 -d "${pkgdir}/usr/lib/systemd/system"
+ install -m755 "${srcdir}/usr/bin/hptsvr" "${pkgdir}/usr/bin/"
+ install -m644 "${srcdir}/hptwebgui.service" "${pkgdir}/usr/lib/systemd/system/"
+ cp -R "${srcdir}/usr/share/hpt/"* "${pkgdir}/usr/share/hpt"
+}
diff --git a/hptwebgui.install b/hptwebgui.install
new file mode 100644
index 000000000000..0a7ea9d7a02b
--- /dev/null
+++ b/hptwebgui.install
@@ -0,0 +1,9 @@
+post_install() {
+ touch /etc/hptcfg
+ echo "hptiop" > /etc/hptcfg
+ echo "Make sure to enter the correct driver in /etc/hptcfg"
+ echo "Start the WebGUI daemon with 'systemctl start hptwebgui'"
+ echo "The WebGUI is available at: http://localhost:7402"
+ echo " Default username: RAID"
+ echo " Default password: hpt"
+}
diff --git a/hptwebgui.service b/hptwebgui.service
new file mode 100644
index 000000000000..39fd49b0a80f
--- /dev/null
+++ b/hptwebgui.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=HighPoint RocketRAID webGUI daemon
+After=network.target
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/hptsvr /etc/hptcfg
+ExecStop=/usr/bin/hptsvr --kill /etc/hptcfg
+Restart=on-failure
+RestartSec=5s
+
+[Install]
+WantedBy=default.target