summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiero Olmeda2023-03-31 15:34:02 +0700
committerPiero Olmeda2023-03-31 15:34:02 +0700
commitc7c3e5682d23fccfc6085b112585ef45c74ea1eb (patch)
tree3ac828baf9488008bfe26be64c3576746bf37e3e
parent33ee765dc1d162f052c6b4219fe2d1dd6ef0f3fb (diff)
downloadaur-c7c3e5682d23fccfc6085b112585ef45c74ea1eb.tar.gz
Removed conflicts
-rwxr-xr-x.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--hqplayer-embedded.install6
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02d70cd9382a..2a140a6cdba4 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = hqplayer-embedded
pkgdesc = Signalyst HQPlayer Embedded HQPlayer - the high-end upsampling multichannel software HD-audio player
pkgver = 4.34.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.signalyst.com/custom.html
install = hqplayer-embedded.install
arch = x86_64
+ arch = x86_64_v3
arch = aarch64
license = custom
depends = alsa-lib
@@ -24,17 +25,14 @@ pkgbase = hqplayer-embedded
depends = mpg123
depends = lame
optdepends = hqplayer-client
- provides = hqplayer
- conflicts = hqplayer-embedded-amd
- conflicts = hqplayer-embedded-sse
- conflicts = hqplayer-embedded-rocm
- conflicts = hqplayer4
source = hqplayerd.service
source = hqplayerd_user.service
sha256sums = 7a61af6b213a44003545e7dace4bd2b6cd7e7d5caa053a2d887750ab35a5a2e1
sha256sums = 5d4194a704979b3ff92482e155769460906745a66e759142eba33a2226f9cb3a
source_x86_64 = https://www.signalyst.eu/bins/hqplayerd/jammy/hqplayerd_4.34.2-157avx2_amd64.deb
sha256sums_x86_64 = 54ae6039fc553b8cf7a28ccad64a1567e4802366f10449b350922517af84b049
+ source_x86_64_v3 = https://www.signalyst.eu/bins/hqplayerd/jammy/hqplayerd_4.34.2-157avx2_amd64.deb
+ sha256sums_x86_64_v3 = 54ae6039fc553b8cf7a28ccad64a1567e4802366f10449b350922517af84b049
source_aarch64 = https://www.signalyst.eu/bins/hqplayerd/bullseye/hqplayerd_4.34.2-156_arm64.deb
sha256sums_aarch64 = 52f70ef6aba7bb0c736623202ee11e446f2f5423051b80409305c67a3fc01dd2
diff --git a/PKGBUILD b/PKGBUILD
index be9119757f14..40c8f6e7e8b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,29 @@ pkgname=hqplayer-embedded
_debpkgver=4.34.2-157avx2
_debpkgverarm=4.34.2-156
pkgver=4.34.2
-pkgrel=1
+pkgrel=2
pkgdesc="Signalyst HQPlayer Embedded
HQPlayer - the high-end upsampling multichannel software HD-audio player"
-arch=('x86_64' 'aarch64')
+arch=('x86_64' 'x86_64_v3' 'aarch64')
url="http://www.signalyst.com/custom.html"
license=('custom')
depends=('alsa-lib' 'glibc' 'libusb-compat' 'flac' 'gcc-libs' 'libgmpris' 'glib2' 'rygel' 'zip' 'unzip' 'wavpack' 'gupnp' 'gupnp-av' 'openmp' 'mpg123' 'lame')
optdepends=('hqplayer-client')
-conflicts=('hqplayer-embedded-amd' 'hqplayer-embedded-sse' 'hqplayer-embedded-rocm' 'hqplayer4')
-provides=('hqplayer')
source=('hqplayerd.service'
'hqplayerd_user.service'
)
source_x86_64=("https://www.signalyst.eu/bins/hqplayerd/jammy/hqplayerd_"$_debpkgver"_amd64.deb")
+source_x86_64_v3=("https://www.signalyst.eu/bins/hqplayerd/jammy/hqplayerd_"$_debpkgver"_amd64.deb")
source_aarch64=("https://www.signalyst.eu/bins/hqplayerd/bullseye/hqplayerd_"$_debpkgverarm"_arm64.deb")
sha256sums=('7a61af6b213a44003545e7dace4bd2b6cd7e7d5caa053a2d887750ab35a5a2e1'
'5d4194a704979b3ff92482e155769460906745a66e759142eba33a2226f9cb3a')
sha256sums_x86_64=('54ae6039fc553b8cf7a28ccad64a1567e4802366f10449b350922517af84b049')
+sha256sums_x86_64_v3=('54ae6039fc553b8cf7a28ccad64a1567e4802366f10449b350922517af84b049')
sha256sums_aarch64=('52f70ef6aba7bb0c736623202ee11e446f2f5423051b80409305c67a3fc01dd2')
install=${pkgname}.install
package() {
- if [[ "$CARCH" = "x86_64" ]]; then
+ if [[ "$CARCH" = "x86_64" ]] || [[ "$CARCH" = "x86_64_v3" ]]; then
bsdtar xf data.tar.zst -C "$pkgdir"
else
bsdtar xf data.tar.xz -C "$pkgdir"
@@ -38,8 +38,6 @@ package() {
rm -rf "$pkgdir/lib"
rm "$pkgdir/usr/share/doc/hqplayerd/copyright"
- cp "$pkgdir"/opt/hqplayerd/lib/* "$pkgdir"/usr/lib/
- rm -rf "$pkgdir/opt"
rm -rf "$pkgdir/etc/modules-load.d"
rm -rf "$pkgdir/etc/udev"
}
diff --git a/hqplayer-embedded.install b/hqplayer-embedded.install
index 0379a9a380bf..6aaee296a808 100644
--- a/hqplayer-embedded.install
+++ b/hqplayer-embedded.install
@@ -19,6 +19,9 @@ if [ ! -f "/etc/pki/tls/certs/ca-bundle.crt" ]; then
mkdir -p /etc/pki/tls/certs
ln -s /etc/ssl/certs/ca-certificates.crt /etc/pki/tls/certs/ca-bundle.crt
fi
+if [ ! -f "libsgllnx64-2.29.02.so" ]; then
+ln -s /opt/hqplayerd/lib/libsgllnx64-2.29.02.so libsgllnx64-2.29.02.so
+fi
}
post_upgrade() {
@@ -42,4 +45,7 @@ if [ ! -f "/etc/pki/tls/certs/ca-bundle.crt" ]; then
mkdir -p /etc/pki/tls/certs
ln -s /etc/ssl/certs/ca-certificates.crt /etc/pki/tls/certs/ca-bundle.crt
fi
+if [ ! -f "libsgllnx64-2.29.02.so" ]; then
+ln -s /opt/hqplayerd/lib/libsgllnx64-2.29.02.so libsgllnx64-2.29.02.so
+fi
}