summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2020-10-10 14:57:56 +1100
committerMatthew Gamble2020-10-10 14:57:56 +1100
commit6374966dc526495a97d1f9657cb7834b356ea939 (patch)
tree4eab183817ca5ed544141099ccad72c8fda2157b
downloadaur-6374966dc526495a97d1f9657cb7834b356ea939.tar.gz
Initial commit of initial version
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d87e92a97d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hr-rust
+ pkgdesc = hr in rust
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/djmattyg007/hr-rust
+ arch = i686
+ arch = x86_64
+ license = custom:Public Domain
+ makedepends = cargo
+ provides = hr
+ conflicts = hr
+ source = https://github.com/djmattyg007/hr-rust/archive/1.0.0.tar.gz
+ sha512sums = 84a908201fd4903f1549663187252a1f438ed1db6148fb938184d4b87b6a87fd80d8d9669f985fdc9aeaac5ccdb9a01a4086f6541a4f46b589faf970119027dd
+
+pkgname = hr-rust
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..33c4a1685cd2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.tar.gz
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..036285e93c51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
+pkgname=hr-rust
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="hr in rust"
+arch=("i686" "x86_64")
+url="https://github.com/djmattyg007/hr-rust"
+license=('custom:Public Domain')
+source=("https://github.com/djmattyg007/hr-rust/archive/${pkgver}.tar.gz")
+sha512sums=("84a908201fd4903f1549663187252a1f438ed1db6148fb938184d4b87b6a87fd80d8d9669f985fdc9aeaac5ccdb9a01a4086f6541a4f46b589faf970119027dd")
+makedepends=("cargo")
+conflicts=("hr")
+provides=("hr")
+
+package() {
+ cd "${srcdir}/hr-rust-${pkgver}"
+ cargo install --no-track --locked --all-features --root "${pkgdir}/usr/" --path .
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/hr-rust/LICENSE.txt"
+}