summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2021-07-10 17:49:52 +1000
committerMatthew Gamble2021-07-10 17:49:52 +1000
commit74387a8facad15cabd89860931b4a1017d24e27a (patch)
tree1a9254ed19a05bf740dda7356ed0cfd847fc0df6
parent7b25383c8cc72a2e7c78aa3a798381cb49366ad2 (diff)
downloadaur-hr-zig.tar.gz
Update to latest release to handle zig 0.8.0 changes
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9aa1d200f5c5..06a9ef097925 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = hr-zig
pkgdesc = hr in zig
- pkgver = 1.0.0
+ pkgver = 1.0.1
pkgrel = 1
url = https://github.com/djmattyg007/hr-zig
arch = i686
arch = x86_64
license = custom:Public Domain
makedepends = zig
+ depends = glibc
provides = hr
conflicts = hr
- source = https://github.com/djmattyg007/hr-zig/archive/1.0.0.tar.gz
- sha512sums = 6574abeb70b855ddb5c8002ffaf7340efc1b029d2998fcfb08faddd455efd5594355762253ad14fb1f64a3db569afe42175df43bd99a710fb447bd0d4371ca63
+ source = https://github.com/djmattyg007/hr-zig/archive/1.0.1.tar.gz
+ sha512sums = 11c7e89584b7e45ec75ad08121d7542a1c7a743052c3333c4c4b31fedb11a50f1aa6a62f997aca74ea1b22211673786ba87581f9d67d8876590339491e55ae2e
pkgname = hr-zig
-
diff --git a/PKGBUILD b/PKGBUILD
index 7a19b18beb7e..ca51fa784fb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
# Maintainer: Matthew Gamble <git@matthewgamble.net>
pkgname=hr-zig
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc="hr in zig"
-arch=('i686' 'x86_64')
+arch=("i686" "x86_64")
url="https://github.com/djmattyg007/hr-zig"
license=('custom:Public Domain')
-source=("https://github.com/djmattyg007/hr-zig/archive/${pkgver}.tar.gz")
-sha512sums=("6574abeb70b855ddb5c8002ffaf7340efc1b029d2998fcfb08faddd455efd5594355762253ad14fb1f64a3db569afe42175df43bd99a710fb447bd0d4371ca63")
+depends=("glibc")
makedepends=("zig")
conflicts=("hr")
provides=("hr")
+source=("https://github.com/djmattyg007/hr-zig/archive/${pkgver}.tar.gz")
+sha512sums=("11c7e89584b7e45ec75ad08121d7542a1c7a743052c3333c4c4b31fedb11a50f1aa6a62f997aca74ea1b22211673786ba87581f9d67d8876590339491e55ae2e")
build() {
cd "${srcdir}/hr-zig-${pkgver}"
+
zig build install -Drelease-small
}
package() {
cd "${srcdir}/hr-zig-${pkgver}"
+
zig build install -Drelease-small --prefix "${pkgdir}/usr"
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/hr-zig/LICENSE.txt"
}