summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-08-22 19:36:32 -0400
committeracxz2020-08-22 19:36:32 -0400
commitaffbbd8437b523c7168a1e9e79fe8960b083f25a (patch)
tree8b7c409e5a21182814e577b6b70988586f4448ee
parent52dbf74c0f2768dc7e8e17040d5983211ebdba3a (diff)
downloadaur-affbbd8437b523c7168a1e9e79fe8960b083f25a.tar.gz
[hsa-rocr] add xxd dep
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 546700ab99e9..41d8c3cb6bf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = hsa-rocr
pkgdesc = ROCm Platform Runtime: ROCr a HPC market enhanced HSA based runtime
pkgver = 3.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://rocmdocs.amd.com/en/latest/Installation_Guide/ROCR-Runtime.html
arch = x86_64
license = custom:NCSAOSL
makedepends = cmake
depends = libelf
depends = hsakmt-roct
+ depends = xxd
provides = rocr-runtime=3.7.0
conflicts = rocr-runtime
replaces = rocr-runtime
diff --git a/PKGBUILD b/PKGBUILD
index f80b340f9544..d6103efd2005 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@
pkgname=hsa-rocr
pkgver=3.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='ROCm Platform Runtime: ROCr a HPC market enhanced HSA based runtime'
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/Installation_Guide/ROCR-Runtime.html'
license=('custom:NCSAOSL')
-depends=('libelf' 'hsakmt-roct')
+depends=('libelf' 'hsakmt-roct' 'xxd')
makedepends=('cmake')
provides=("rocr-runtime=$pkgver")
replaces=('rocr-runtime')
@@ -30,8 +30,6 @@ prepare() {
build() {
cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -DHSAKMT_INC_PATH=/opt/rocm/include \
- -DHSAKMT_LIB_PATH=/opt/rocm/lib \
"$_dirname/src"
make
}