summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Knapp2020-03-27 11:02:10 -0700
committerJonathan Knapp2020-03-27 11:02:10 -0700
commitd9412e9af7b489cb9deb383ffb93b5b2cdf5f97d (patch)
treef9f63c2fef363f696c4fbd272ba82f0a834367fa
parentdc649e162a4e7285b0c4f511a4b47927a5912b61 (diff)
downloadaur-d9412e9af7b489cb9deb383ffb93b5b2cdf5f97d.tar.gz
Fix permissions issue
-rw-r--r--PKGBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e50657d9e6b..781f94e90c54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,6 +26,7 @@ package() {
cd "$pkgname"
npm install -g --prefix "$pkgdir"/usr --user root --unsafe-perm --production
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ chmod -R 755 "$pkgdir"/usr/bin
#HACK: npm is being lame and only installing a symlink =/
rm "$pkgdir/usr/lib/node_modules/hsd"
find * -exec install -D -m644 "{}" "$pkgdir/usr/lib/node_modules/hsd/{}" \;