summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Knapp2018-08-02 12:48:49 -0700
committerJonathan Knapp2018-08-02 12:48:49 -0700
commitebc0c6402e74c15874f77c70a4a406f39019e3a3 (patch)
tree505f77e61512c6b389d5f1fb8115981707cefe83
downloadaur-ebc0c6402e74c15874f77c70a4a406f39019e3a3.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06cf6ad6db81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = hsd-git
+ pkgdesc = Handshake decentralized naming system Daemon & Full Node
+ pkgver = 1.0.0.beta.15.562.g4b04d9a2
+ pkgrel = 1
+ url = http://handshake.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ makedepends = python2
+ makedepends = gcc
+ makedepends = make
+ makedepends = unbound
+ depends = nodejs
+ provides = hsd
+ conflicts = hsd
+ source = hsd-git::git+https://github.com/handshake-org/hsd.git
+ md5sums = SKIP
+
+pkgname = hsd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ed113ea6f9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jonathan Knapp <jaknapp8+aur@gmail.com>
+# Contributor: Christopher Jeffrey
+# URL: https://github.com/handshake-org/hsd
+# Upstream: https://github.com/handshake-org/hsd
+
+pkgname=hsd-git
+pkgver=1.0.0.beta.15.562.g4b04d9a2
+pkgrel=1
+pkgdesc='Handshake decentralized naming system Daemon & Full Node'
+arch=('i686' 'x86_64')
+url='http://handshake.org/'
+license=('MIT')
+depends=('nodejs')
+makedepends=('git' 'npm' 'python2' 'gcc' 'make' 'unbound')
+provides=('hsd')
+conflicts=('hsd')
+source=("$pkgname::git+https://github.com/handshake-org/hsd.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe | sed 's/^v//;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ npm install -g --prefix "$pkgdir"/usr --user root --unsafe-perm
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ #HACK: npm is being lame and only installing a symlink =/
+ rm "$pkgdir/usr/lib/node_modules/hsd"
+ find * -exec install -D -m644 "{}" "$pkgdir/usr/lib/node_modules/hsd/{}" \;
+ find "$pkgdir/usr/lib/node_modules/hsd" -exec chmod +x "{}" \;
+
+ #HACK: remove references to $srcdir & $pkgdir (if you care)
+ # npm install -g removeNPMAbsolutePaths --prefix "$pkgdir"/usr
+ # "$pkgdir"/usr/bin/removeNPMAbsolutePaths "$pkgdir"/usr
+ # npm uninstall -g removeNPMAbsolutePaths --prefix "$pkgdir"/usr
+}