summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2024-04-10 04:49:17 +0200
committerMichal Wojdyla2024-04-10 04:49:17 +0200
commit3ca893d38ee98764e09cafbe01fa3025d492bacf (patch)
tree21b06968f560ac3ab44bddc27ff352e198bd02f1
downloadaur-3ca893d38ee98764e09cafbe01fa3025d492bacf.tar.gz
upload (with semi-arbitrary commit picked)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD42
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d540cd78de5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hsh
+ pkgdesc = better shell
+ pkgver = 0.0.2.76.gd82ba32
+ pkgrel = 1
+ url = https://github.com/GrayHatter/hsh
+ arch = x86_64
+ license = unknown
+ makedepends = zig
+ makedepends = git
+ source = hsh::git+https://github.com/GrayHatter/hsh#commit=d82ba323ad46288f136038c53c843acaa9997e99
+ sha256sums = SKIP
+
+pkgname = hsh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccf3b3c68fca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
+
+pkgname=hsh
+pkgver=0.0.2.76.gd82ba32
+_gitcommit=d82ba323ad46288f136038c53c843acaa9997e99
+pkgrel=1
+pkgdesc="better shell"
+arch=('x86_64')
+url="https://github.com/GrayHatter/hsh"
+license=('unknown')
+makedepends=('zig' 'git')
+source=(
+ "${pkgname}::git+$url#commit=$_gitcommit"
+)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --always | sed 's|-|.|g' | cut -f2 -d"v"
+}
+
+build() {
+ cd "$pkgname"
+ DESTDIR="build" zig build \
+ --prefix /usr \
+ --search-prefix /usr \
+ -Dtarget=native-linux.5.15-gnu \
+ -Dcpu=baseline
+}
+
+check() {
+ cd "$pkgname"
+ zig build test \
+ -Dtarget=native-linux.5.15-gnu \
+ -Dcpu=baseline
+}
+
+package() {
+ cd "$pkgname"
+ cp -a build/* "$pkgdir"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+}