summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchris2015-06-08 17:00:25 +0200
committerchris2015-06-08 17:00:25 +0200
commit22122e27a0e7b3020d4c3ad87172d82be330f841 (patch)
tree7bd8ab8f7fb55885d6735d68ffab39f0bec1a2fd
downloadaur-22122e27a0e7b3020d4c3ad87172d82be330f841.tar.gz
Initial commit to aur4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b59f005fcdc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hstr-git
+ pkgdesc = A command line utility that brings improved BASH command completion from the history. It aims to make completion easier and more efficient than Ctrl-r.
+ pkgver = 1.17.r11.g042501d
+ pkgrel = 1
+ url = https://github.com/dvorka/hstr
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = readline
+ makedepends = ncurses
+ depends = readline
+ conflicts = hh
+ source = git://github.com/dvorka/hstr.git#branch=master
+ md5sums = SKIP
+
+pkgname = hstr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c637137e53ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Christian Wieden <wiedenchr at gmail dot com
+# Contributer: Anthony Vitacco <anthony at littlegno dot me>
+# Original PKGBUILD: Ricardo Band <me at xengi dot de>
+pkgname=hstr-git
+pkgver=1.17.r11.g042501d
+pkgrel=1
+pkgdesc="A command line utility that brings improved BASH command completion from the history. It aims to make completion easier and more efficient than Ctrl-r."
+arch=('i686' 'x86_64')
+url="https://github.com/dvorka/hstr"
+license=('Apache')
+makedepends=('git' 'readline' 'ncurses')
+depends=('readline')
+source=(git://github.com/dvorka/hstr.git#branch=master)
+md5sums=('SKIP')
+conflicts=('hh');
+
+build() {
+ cd "hstr/dist"
+ ./1-dist.sh
+ cd ..
+ sed -i -e "s#<ncursesw/curses.h>#<curses.h>#g" src/include/hstr_curses.h
+ sed -i -e "s#<ncursesw/curses.h>#<curses.h>#g" src/hstr.c
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "hstr"
+ make DESTDIR="$pkgdir/" install
+}
+
+pkgver() {
+ cd "hstr"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}