summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2021-02-06 22:35:45 +0300
committerorhun2021-02-06 22:35:45 +0300
commiteb456bad7276c8f703712e52bf771434ebb201ee (patch)
treee8214928d96d8fe7e8420ab8ccbb05740575367e
parentb2ab685d66fa4129c3998d87e0edb96a38a69a79 (diff)
downloadaur-eb456bad7276c8f703712e52bf771434ebb201ee.tar.gz
upgpkg: ht 0.4.0-1
upstream release
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD84
2 files changed, 31 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 159795981ce6..f07dc8441aad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,13 @@
pkgbase = ht
- pkgdesc = executable file editor viewer analyzer for MZ, PE and LE. Formerly ht-editor
- pkgver = 2.1.0
- pkgrel = 7
- url = https://github.com/sebastianbiallas/ht
- arch = i686
+ pkgdesc = Yet another HTTPie clone
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/ducaale/ht
arch = x86_64
- license = GPL
- makedepends = texinfo
+ license = MIT
+ makedepends = rust
depends = gcc-libs
- depends = ncurses
- depends = lzo
- conflicts = ht-editor
- replaces = ht-editor
- source = https://downloads.sourceforge.net/sourceforge/hte/ht-2.1.0.tar.bz2
- source = 0000-abs-uint-ambiguous.patch
- md5sums = 09b2a4461d75e9cd03af1cd67fadc1ec
- md5sums = 580d1b2879faea507ec30316ef238627
- sha256sums = 31f5e8e2ca7f85d40bb18ef518bf1a105a6f602918a0755bc649f3f407b75d70
- sha256sums = 58e7a080756eb81ae8ca479d909bcd375e40a359b43e6b70a0177f2c28ace938
+ source = ht-0.4.0.tar.gz::https://github.com/ducaale/ht/archive/v0.4.0.tar.gz
+ sha256sums = 5c7e6ff620b3206b395b9b839950dd5ccd62820855eb6b1e4d401ac32b42aa4e
pkgname = ht
-
diff --git a/PKGBUILD b/PKGBUILD
index c2329e682720..259bcf2bca2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,69 +1,31 @@
-# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
-# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
-# Contributor: Remi Gacogne <rgacogne-arch at coredump dot fr> # AUR: ht-editor
-# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Contributor: tardo <tardo@nagi-fanboi.net>
-# Contributor: Simon Morgan <"mra84964@mra.pb.hx".decode('rot-13')>
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
-set -u
-pkgname='ht'
-pkgver='2.1.0'
-pkgrel='7'
-pkgdesc='executable file editor viewer analyzer for MZ, PE and LE. Formerly ht-editor'
-arch=('i686' 'x86_64')
-#url='http://hte.sourceforge.net/'
-#url='http://sourceforge.net/projects/hte/'
-url='https://github.com/sebastianbiallas/ht'
-license=('GPL')
-depends=('gcc-libs' 'ncurses' 'lzo')
-# lzo provides lzo2
-# depends+=('libx11') # --disable-x11-textmode
-makedepends=('texinfo')
-conflicts=('ht-editor')
-replaces=('ht-editor')
-source=("https://downloads.sourceforge.net/sourceforge/hte/${pkgname}-${pkgver}.tar.bz2")
-source+=('0000-abs-uint-ambiguous.patch') # Issue #19
-md5sums=('09b2a4461d75e9cd03af1cd67fadc1ec'
- '580d1b2879faea507ec30316ef238627')
-sha256sums=('31f5e8e2ca7f85d40bb18ef518bf1a105a6f602918a0755bc649f3f407b75d70'
- '58e7a080756eb81ae8ca479d909bcd375e40a359b43e6b70a0177f2c28ace938')
-
-prepare() {
- set -u
- cd "ht-${pkgver}"
- # https://stackoverflow.com/questions/1100090/looking-for-an-efficient-integer-square-root-algorithm-for-arm-thumb2
- #diff -pNau5 htapp.cc{.orig,} > '../0000-abs-uint-ambiguous.patch'
- patch -Nbup0 -i "${srcdir}/0000-abs-uint-ambiguous.patch"
- set +u
-}
+pkgname=ht
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Yet another HTTPie clone"
+arch=('x86_64')
+url="https://github.com/ducaale/ht"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('rust')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('5c7e6ff620b3206b395b9b839950dd5ccd62820855eb6b1e4d401ac32b42aa4e')
build() {
- set -u
- cd "${pkgname}-${pkgver}"
- if [ ! -s 'Makefile' ]; then
- ./configure --disable-x11-textmode --enable-release --prefix='/usr'
- fi
-
- local _mflags=()
- _mflags+='CXXFLAGS=-Wno-narrowing'
- local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
- if [ -z "${MAKEFLAGS:=}" ] || [ "${MAKEFLAGS//-j/}" = "${MAKEFLAGS}" ]; then
- _mflags+=('-j' "${_nproc}")
- fi
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked
+}
- nice make -s "${_mflags[@]}"
- set +u
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release --locked
}
package() {
- set -u
- cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- # avoid TeX conflict
- mv "${pkgdir}/usr/bin/ht" "${pkgdir}/usr/bin/hte"
- # doc
- install -Dpm0644 doc/*.info -t "${pkgdir}/usr/share/info/"
- install -Dpm0644 doc/{README,*.html} -t "${pkgdir}/usr/share/doc/ht/"
- set +u
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}
-set +u