summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hartmann2020-04-18 13:59:05 +0200
committerThomas Hartmann2020-04-18 13:59:05 +0200
commit1c1fdadb2c819b11890b2eebe705ad9e2d0b8cd4 (patch)
tree01a6131c3ddaedad337f6f2a4b7a3bdd793e12c4
parente34893c00f610e4b79223fd5ecfae0848483c7fc (diff)
downloadaur-1c1fdadb2c819b11890b2eebe705ad9e2d0b8cd4.tar.gz
follow packaging guidelines and pull from github
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c5bb5e5f7e8..d70ec2279d22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
pkgbase = htcondor
+ pkgdesc = Distributed workload management system
pkgver = 8.8.8
- pkgrel = 1
+ pkgrel = 2
+ url = https://research.cs.wisc.edu/htcondor/
arch = x86_64
- license = GPL
+ license = apache
makedepends = cmake
depends = boost
depends = munge
@@ -16,8 +18,8 @@ pkgbase = htcondor
depends = python
provides = htcondor
conflicts = htcondor
- source = https://research.cs.wisc.edu/htcondor/debian/8.8/buster/pool/contrib/c/condor/condor_8.8.8.orig.tar.gz
- md5sums = SKIP
+ source = https://github.com/htcondor/htcondor/archive/V8_8_8.tar.gz
+ md5sums = e248a1506d367cacab0575fb18aa1e11
pkgname = htcondor
diff --git a/PKGBUILD b/PKGBUILD
index ec3d63e69cbc..dba313aef228 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
-# Maintainer: Your Name <youremail@domain.com>
+# Maintainer: Thomas Hartmann <thomas@th-ht.de>
pkgname=htcondor
pkgver=8.8.8
-pkgrel=1
+pkgrel=2
epoch=
-pkgdesc=""
+pkgdesc="Distributed workload management system"
arch=("x86_64")
-url=""
-license=('GPL')
+url="https://research.cs.wisc.edu/htcondor/"
+license=('apache')
groups=()
depends=("boost" "munge" "libxss" "curl" "gawk" "java-runtime" "libcgroup" "pcre" "sqlite" "python")
makedepends=("cmake")
@@ -24,13 +24,13 @@ backup=()
options=()
install=
changelog=
-source=("https://research.cs.wisc.edu/htcondor/debian/8.8/buster/pool/contrib/c/condor/condor_$pkgver.orig.tar.gz")
+source=("https://github.com/htcondor/htcondor/archive/V${pkgver//./_}.tar.gz")
noextract=()
-md5sums=('SKIP')
+md5sums=('e248a1506d367cacab0575fb18aa1e11')
validpgpkeys=()
build() {
- cd "condor-$pkgver"
+ cd "htcondor-${pkgver//./_}"
mkdir -p build_folder
cd build_folder
cmake -DSYSTEM_NAME=arch -DWITH_VOMS=False -DWITH_GLOBUS=False -DWITH_PYTHON_BINDINGS=False -DCMAKE_INSTALL_PREFIX=/opt/htcondor ../
@@ -38,9 +38,9 @@ build() {
}
package() {
- cd "condor-$pkgver/build_folder"
+ cd "htcondor-${pkgver//./_}/build_folder"
make DESTDIR="$pkgdir/" install
-
+
echo "export PATH=$PATH:/opt/htcondor/bin" > $srcdir/htcondor.sh
install -Dm644 $srcdir/htcondor.sh $pkgdir/etc/profile.d/htcondor.sh
}