summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hartmann2020-04-18 13:33:45 +0200
committerThomas Hartmann2020-04-18 13:33:45 +0200
commite34893c00f610e4b79223fd5ecfae0848483c7fc (patch)
treebd0487c16ac0cd97a580ee459fc075f9f65176b7
downloadaur-e34893c00f610e4b79223fd5ecfae0848483c7fc.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD46
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c5bb5e5f7e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = htcondor
+ pkgver = 8.8.8
+ pkgrel = 1
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = boost
+ depends = munge
+ depends = libxss
+ depends = curl
+ depends = gawk
+ depends = java-runtime
+ depends = libcgroup
+ depends = pcre
+ depends = sqlite
+ depends = python
+ provides = htcondor
+ conflicts = htcondor
+ source = https://research.cs.wisc.edu/htcondor/debian/8.8/buster/pool/contrib/c/condor/condor_8.8.8.orig.tar.gz
+ md5sums = SKIP
+
+pkgname = htcondor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec3d63e69cbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=htcondor
+pkgver=8.8.8
+pkgrel=1
+epoch=
+pkgdesc=""
+arch=("x86_64")
+url=""
+license=('GPL')
+groups=()
+depends=("boost" "munge" "libxss" "curl" "gawk" "java-runtime" "libcgroup" "pcre" "sqlite" "python")
+makedepends=("cmake")
+checkdepends=()
+optdepends=()
+provides=("htcondor")
+conflicts=("htcondor")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://research.cs.wisc.edu/htcondor/debian/8.8/buster/pool/contrib/c/condor/condor_$pkgver.orig.tar.gz")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "condor-$pkgver"
+ mkdir -p build_folder
+ cd build_folder
+ cmake -DSYSTEM_NAME=arch -DWITH_VOMS=False -DWITH_GLOBUS=False -DWITH_PYTHON_BINDINGS=False -DCMAKE_INSTALL_PREFIX=/opt/htcondor ../
+ make
+}
+
+package() {
+ cd "condor-$pkgver/build_folder"
+ make DESTDIR="$pkgdir/" install
+
+ echo "export PATH=$PATH:/opt/htcondor/bin" > $srcdir/htcondor.sh
+ install -Dm644 $srcdir/htcondor.sh $pkgdir/etc/profile.d/htcondor.sh
+}