summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-13 03:07:24 +0300
committerDimitris Kiziridis2020-05-13 03:07:24 +0300
commit79039942cec56261778b875e2abff965d9ff20e4 (patch)
treed71e5b696fa5d1d6f2a343da55adbd700e39f1d8
parent35eae9a00f5f650e61f6695dac68c1ea241e0676 (diff)
downloadaur-79039942cec56261778b875e2abff965d9ff20e4.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14120883d11f..813f4d86f650 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,8 +6,10 @@ pkgbase = htconvert
arch = any
license = MIT
makedepends = npm
- source = https://github.com/lukechilds/htconvert/archive/v1.0.7.tar.gz
- md5sums = ccf064d328ab6d17af4074e9d29b2954
+ depends = bash
+ depends = nodejs
+ source = htconvert-1.0.7.tar.gz::https://github.com/lukechilds/htconvert/archive/v1.0.7.tar.gz
+ sha256sums = 73b534a15d61f935f8724e584ab14abe58bc476e6971a2df0ce765b68f4796cc
pkgname = htconvert
diff --git a/PKGBUILD b/PKGBUILD
index 0693dcfca864..f57c03ee3c03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,10 @@ pkgdesc="Convert .htaccess redirects to nginx.conf redirects"
arch=('any')
url='https://github.com/lukechilds/htconvert'
license=('MIT')
+depends=('bash' 'nodejs')
makedepends=('npm')
-source=("${url}/archive/v${pkgver}.tar.gz")
-md5sums=('ccf064d328ab6d17af4074e9d29b2954')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('73b534a15d61f935f8724e584ab14abe58bc476e6971a2df0ce765b68f4796cc')
build() {
cd ${srcdir}/${pkgname}-${pkgver}