summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsseneca2021-02-02 23:23:00 +0000
committersseneca2021-02-02 23:23:00 +0000
commit77429722eafcd7d986c0d273e6a3a3d7662e40c0 (patch)
tree9e8bbb801f4a2a32590e140c3598bab0c959eb41
downloadaur-77429722eafcd7d986c0d273e6a3a3d7662e40c0.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0be202c4eacd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = html5validator
+ pkgdesc = Command line tool to validate HTML5 files.
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://github.com/svenkreiss/html5validator
+ arch = any
+ license = MIT
+ makedepends = python
+ depends = python-yaml
+ depends = java-environment-openjdk=8
+ source = https://github.com/svenkreiss/html5validator/archive/v0.3.3/html5validator-0.3.3.tar.gz
+ sha512sums = 28299180c3ae77f7a1eca731781ad52eab7aed02ae1f3eecf917f5eb9ff891b7e778d5581dfbb06d45527889b8992af478a7d99534eb366a750e80445d708a94
+
+pkgname = html5validator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..feb21b6b5ca5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: sseneca <me at ssene dot ca>
+pkgname=html5validator
+pkgver=0.3.3
+pkgrel=1
+pkgdesc="Command line tool to validate HTML5 files."
+arch=('any')
+url="https://github.com/svenkreiss/html5validator"
+license=('MIT')
+depends=('python-yaml' 'java-environment-openjdk=8')
+makedepends=('python')
+source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('28299180c3ae77f7a1eca731781ad52eab7aed02ae1f3eecf917f5eb9ff891b7e778d5581dfbb06d45527889b8992af478a7d99534eb366a750e80445d708a94')
+
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}