summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Dziedzic2011-11-13 21:01:01 +0000
committerSandy Carter2015-08-14 16:58:29 -0400
commit03d8927357792d23c462e1063401323aa6d0afe4 (patch)
treee79bb849816aa72a348095dbbfe956bad1f6f045
parent36655274be93830242f9c8cc6d4ad9a7c6a3fa3f (diff)
downloadaur-03d8927357792d23c462e1063401323aa6d0afe4.tar.gz
updated on Sun Nov 13 21:01:01 UTC 2011
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--missing-header.patch10
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e3dc1a67d5c..81b1674e9ae6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = htmlcxx
pkgdesc = A simple non-validating css1 and html parser for C++.
pkgver = 0.85
- pkgrel = 1
+ pkgrel = 2
url = http://htmlcxx.sourceforge.net/
arch = i686
arch = x86_64
@@ -13,7 +13,9 @@ pkgbase = htmlcxx
conflicts = libhtmlcxx
conflicts = libcss_parser
source = http://kent.dl.sourceforge.net/project/htmlcxx/htmlcxx/0.85/htmlcxx-0.85.tar.gz
+ source = missing-header.patch
md5sums = dbe13c25b5846eb7cbbfa63d85f00f74
+ md5sums = 6c89882e310e9945fb0f4cdbb1f965bf
pkgname = htmlcxx
diff --git a/PKGBUILD b/PKGBUILD
index a14db55f3936..62fb0c13ae60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=htmlcxx
pkgver=0.85
-pkgrel=1
+pkgrel=2
pkgdesc="A simple non-validating css1 and html parser for C++."
arch=('i686' 'x86_64')
url="http://htmlcxx.sourceforge.net/"
@@ -11,12 +11,17 @@ depends=()
makedepends=()
conflicts=('htmlcxx' 'libhtmlcxx' 'libcss_parser')
provides=('htmlcxx' 'libhtmlcxx' 'libcss_parser')
-source=("http://kent.dl.sourceforge.net/project/htmlcxx/htmlcxx/$pkgver/htmlcxx-$pkgver.tar.gz")
-md5sums=(dbe13c25b5846eb7cbbfa63d85f00f74)
+source=("http://kent.dl.sourceforge.net/project/htmlcxx/htmlcxx/$pkgver/htmlcxx-$pkgver.tar.gz"
+ "missing-header.patch")
+md5sums=(dbe13c25b5846eb7cbbfa63d85f00f74
+ 6c89882e310e9945fb0f4cdbb1f965bf)
+
+# Thanks to jgehring for the patch.
build() {
cd "$srcdir/htmlcxx-$pkgver"
+ patch -p1 -i "$srcdir/missing-header.patch"
./configure --prefix=/usr
make
}
diff --git a/missing-header.patch b/missing-header.patch
new file mode 100644
index 000000000000..f2993f935883
--- /dev/null
+++ b/missing-header.patch
@@ -0,0 +1,10 @@
+--- htmlcxx-0.85/html/tree.h
++++ htmlcxx-0.85/html/tree.h
+@@ -46,6 +46,7 @@
+ #define tree_hh_
+
+ #include <cassert>
++#include <cstddef>
+ #include <memory>
+ #include <stdexcept>
+ #include <iterator>