summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothee2016-01-10 15:00:04 +0100
committerTimothee2016-01-10 15:00:04 +0100
commit30f7a7c9238af9e77c69678138f86227d0ac642c (patch)
tree98ec901ab01973241e4effb53b198058c5bba91d
parent80bed365dcdd766e748e75f5776588f0433fe38c (diff)
downloadaur-30f7a7c9238af9e77c69678138f86227d0ac642c.tar.gz
update to 0.86 version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
-rw-r--r--missing-header.patch10
3 files changed, 13 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31daaa143a64..462784c4aaf9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Jan 10 13:59:15 UTC 2016
pkgbase = htmlcxx
pkgdesc = A simple non-validating CSS1 and HTML parser for C++.
- pkgver = 0.85
- pkgrel = 4
+ pkgver = 0.86
+ pkgrel = 1
url = http://htmlcxx.sourceforge.net/
arch = i686
arch = x86_64
@@ -12,10 +14,8 @@ pkgbase = htmlcxx
conflicts = htmlcxx
conflicts = libhtmlcxx
conflicts = libcss_parser
- source = http://heanet.dl.sourceforge.net/project/htmlcxx/htmlcxx/0.85/htmlcxx-0.85.tar.gz
- source = missing-header.patch
- sha256sums = ab02a0c4addc82f82d564f7d163fe0cc726179d9045381c288f5b8295996bae5
- sha256sums = 2df7ea556410979f4ede3cb70d2067ba83eaadd437e3f68d67d0834cc8e4d33c
+ source = http://downloads.sourceforge.net/project/htmlcxx/htmlcxx/0.86/htmlcxx-0.86.tar.gz
+ sha256sums = 07542b5ea2442143b125ba213b6823ff4a23fff352ecdd84bbebe1d154f4f5c1
pkgname = htmlcxx
diff --git a/PKGBUILD b/PKGBUILD
index e78543785949..2b8f9486a2ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Eduardo Sánchez Muñoz <eduardosanchezmunoz@gmail.com>
+# Maintainer: Timothée Girard <aur@timotheegirard.com>
+# Contributor: Eduardo Sánchez Muñoz <eduardosanchezmunoz@gmail.com>
pkgname=htmlcxx
-pkgver=0.85
-pkgrel=4
+pkgver=0.86
+pkgrel=1
pkgdesc="A simple non-validating CSS1 and HTML parser for C++."
arch=('i686' 'x86_64')
url="http://htmlcxx.sourceforge.net/"
@@ -11,17 +12,12 @@ depends=()
makedepends=()
conflicts=('htmlcxx' 'libhtmlcxx' 'libcss_parser')
provides=('htmlcxx' 'libhtmlcxx' 'libcss_parser')
-source=("http://heanet.dl.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- "missing-header.patch")
-sha256sums=('ab02a0c4addc82f82d564f7d163fe0cc726179d9045381c288f5b8295996bae5'
- '2df7ea556410979f4ede3cb70d2067ba83eaadd437e3f68d67d0834cc8e4d33c')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('07542b5ea2442143b125ba213b6823ff4a23fff352ecdd84bbebe1d154f4f5c1')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- # Thanks to jgehring for the patch.
- patch -p1 -i "${srcdir}/missing-header.patch"
-
+
LDFLAGS="$LDFLAGS -Wl,--no-as-needed"
./configure --prefix=/usr
make
diff --git a/missing-header.patch b/missing-header.patch
deleted file mode 100644
index f2993f935883..000000000000
--- a/missing-header.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- htmlcxx-0.85/html/tree.h
-+++ htmlcxx-0.85/html/tree.h
-@@ -46,6 +46,7 @@
- #define tree_hh_
-
- #include <cassert>
-+#include <cstddef>
- #include <memory>
- #include <stdexcept>
- #include <iterator>