summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-23 12:19:38 +0000
committerDaniel Bermond2018-11-23 12:19:38 +0000
commit80997f0f94a14e3a73642e3436f6e132de03fd62 (patch)
tree603dc094e8434d9c668196bd6d20a423dadd95b2
parentb117de0c2a781078020f5becaad3fcd015d4a436 (diff)
downloadaur-80997f0f94a14e3a73642e3436f6e132de03fd62.tar.gz
Use https for url. Add missing dependency. Add pgp signature check.
-rw-r--r--.SRCINFO13
-rw-r--r--ChangeLog18
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 965aab270816..81bf4e54f3ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = htmldoc
pkgdesc = HTML Conversion Software
pkgver = 1.9.4
- pkgrel = 2
- url = http://www.msweet.org/htmldoc/index.html
+ pkgrel = 3
+ url = https://www.msweet.org/htmldoc/index.html
changelog = ChangeLog
arch = i686
arch = x86_64
@@ -10,8 +10,13 @@ pkgbase = htmldoc
depends = libxpm
depends = gnutls
depends = fltk
- source = htmldoc-1.9.4.tar.gz::https://github.com/michaelrsweet/htmldoc/archive/v1.9.4.tar.gz
- sha256sums = 663598a33f21b4d180f4ffd7219c68f7c84fedb7f1a253a804830a40befb113c
+ depends = shared-mime-info
+ noextract = htmldoc-1.9.4-source.tar.gz
+ source = https://github.com/michaelrsweet/htmldoc/releases/download/v1.9.4/htmldoc-1.9.4-source.tar.gz
+ source = https://github.com/michaelrsweet/htmldoc/releases/download/v1.9.4/htmldoc-1.9.4-source.tar.gz.sig
+ validpgpkeys = 845464660B686AAB36540B6F999559A027815955
+ sha256sums = 8e33d22e0d757099bcbc09d513dae599bdb735450f2af24597f325a7a854d1f7
+ sha256sums = SKIP
pkgname = htmldoc
diff --git a/ChangeLog b/ChangeLog
index d26598dab717..ac6495864dc3 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,14 +1,26 @@
-2018-10-03 Daniel Bermond < yahoo-com: danielbermond >
+2018-11-23 Daniel Bermond < gmail-com: danielbermond >
+
+ * 1.9.4-3 :
+ use https for url
+ add missing dependency
+ add pgp signature validation check (uses a different source file)
+
+2018-10-26 Daniel Bermond < gmail-com: danielbermond >
+
+ * 1.9.4-2 :
+ do not conflict with the -git variant
+
+2018-10-03 Daniel Bermond < gmail-com: danielbermond >
* 1.9.4-1 :
new upstream release
-2018-05-02 Daniel Bermond < yahoo-com: danielbermond >
+2018-05-02 Daniel Bermond < gmail-com: danielbermond >
* 1.9.3-1 :
new upstream release
-2018-02-07 Daniel Bermond < yahoo-com: danielbermond >
+2018-02-07 Daniel Bermond < gmail-com: danielbermond >
* 1.9.2-1 :
new maintainer
diff --git a/PKGBUILD b/PKGBUILD
index 29570a8dd4cc..ba49ec6c8878 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,15 +8,26 @@
pkgname=htmldoc
pkgver=1.9.4
-pkgrel=2
+pkgrel=3
pkgdesc='HTML Conversion Software'
arch=('i686' 'x86_64')
-url='http://www.msweet.org/htmldoc/index.html'
+url='https://www.msweet.org/htmldoc/index.html'
license=('GPL2')
-depends=('libxpm' 'gnutls' 'fltk')
+depends=('libxpm' 'gnutls' 'fltk' 'shared-mime-info')
changelog=ChangeLog
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/michaelrsweet/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('663598a33f21b4d180f4ffd7219c68f7c84fedb7f1a253a804830a40befb113c')
+source=("https://github.com/michaelrsweet/htmldoc/releases/download/v${pkgver}/htmldoc-${pkgver}-source.tar.gz"{,.sig})
+noextract=("htmldoc-${pkgver}-source.tar.gz")
+sha256sums=('8e33d22e0d757099bcbc09d513dae599bdb735450f2af24597f325a7a854d1f7'
+ 'SKIP')
+validpgpkeys=('845464660B686AAB36540B6F999559A027815955') # Michael R Sweet
+
+prepare() {
+ mkdir -p "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
+
+ # source file misses a top-level directory
+ bsdtar -xf "${srcdir}/htmldoc-${pkgver}-source.tar.gz"
+}
build() {
cd "${pkgname}-${pkgver}"