summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-02-07 22:58:37 -0200
committerDaniel Bermond2018-02-07 22:58:37 -0200
commitdb965ea253e4fba0bce1c32bc634c96f659d1e6f (patch)
tree925910d94e17a6af480ebc9994a40d4f745ad39d
parent85e32e77b5f7518f0be357c4a960b5d4c8d05a6d (diff)
downloadaur-db965ea253e4fba0bce1c32bc634c96f659d1e6f.tar.gz
Updated to version 1.9.2
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD86
-rw-r--r--errno.patch11
-rw-r--r--htmldoc.install13
4 files changed, 31 insertions, 102 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34a74ae0c267..59a8553d6db3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,18 @@
-# Generated by mksrcinfo v8
-# Fri Mar 25 03:31:51 UTC 2016
pkgbase = htmldoc
- pkgdesc = Produce PDF or Postscript from HTML documents including TOCs and Indices
- pkgver = 1.8.29
+ pkgdesc = HTML Conversion Software
+ pkgver = 1.9.2
pkgrel = 1
- url = http://www.htmldoc.org
- install = htmldoc.install
+ url = http://www.msweet.org/htmldoc/index.html
changelog = ChangeLog
arch = i686
arch = x86_64
license = GPL2
depends = libxpm
+ depends = gnutls
depends = fltk
- depends = libjpeg
- depends = openssl
- depends = shared-mime-info
- conflicts = htmldoc-svn
- source = http://www.msweet.org/files/project1/htmldoc-1.8.29-source.tar.gz
- source = errno.patch
- source = htmldoc.install
- md5sums = 14d32bd772e2bc6af7b9b2233724c3ec
- md5sums = 2f48488fd485f2583e02b519d6cef553
- md5sums = 808c3a6920824fdab7b2519d567c92f9
+ conflicts = htmldoc-git
+ source = htmldoc-1.9.2.tar.gz::https://github.com/michaelrsweet/htmldoc/archive/v1.9.2.tar.gz
+ sha256sums = f967654f1cd607f80297f46d774b5607cda80ab8199f358d868a7efa77de35d3
pkgname = htmldoc
diff --git a/PKGBUILD b/PKGBUILD
index 40235d438c4d..e2d6264b2e9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: James An <james@jamesan.ca>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: James An <james@jamesan.ca>
# Contributor: Mariusz Libera <mariusz.libera@gmail.com>
# Contributor: mortdeus <mortdeus@gocos2d.org>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
@@ -6,76 +7,37 @@
# Contributor: Simon Rutishauser <simon.rutishauser@gmx.ch>
pkgname=htmldoc
-pkgver=1.8.29
+pkgver=1.9.2
pkgrel=1
-pkgdesc="Produce PDF or Postscript from HTML documents including TOCs and Indices"
+pkgdesc='HTML Conversion Software'
arch=('i686' 'x86_64')
-url="http://www.htmldoc.org"
+url='http://www.msweet.org/htmldoc/index.html'
license=('GPL2')
-depends=('libxpm' 'fltk' 'libjpeg' 'openssl' 'shared-mime-info')
-conflicts=('htmldoc-svn')
+depends=('libxpm' 'gnutls' 'fltk')
+conflicts=('htmldoc-git')
changelog=ChangeLog
-install=$pkgname.install
-source=(
- "http://www.msweet.org/files/project1/htmldoc-${pkgver}-source.tar.gz"
- 'errno.patch'
- "$pkgname.install"
-)
-md5sums=(
- '14d32bd772e2bc6af7b9b2233724c3ec'
- '2f48488fd485f2583e02b519d6cef553'
- '808c3a6920824fdab7b2519d567c92f9'
-)
-
-prepare() {
- cd "$pkgname-$pkgver"
-
- # replace obsolete libgnutls-config with pkg-config
- grep -rIl 'libgnutls-config --libs' | while read file ; do sed -i 's/libgnutls-config --libs/pkg-config --libs gnutls/' $file ; done
-
- # apply patches
- for patch in ../*.patch ; do
- patch -Np1 -i $patch
- done
-
- # fix desktop file
- echo "MimeType=application/vnd.htmldoc-book;" >> desktop/htmldoc.desktop
- sed -i 's/X-Red-Hat.*$//' desktop/htmldoc.desktop
- sed -i 's/htmldoc.png/htmldoc/' desktop/htmldoc.desktop
-}
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/michaelrsweet/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('f967654f1cd607f80297f46d774b5607cda80ab8199f358d868a7efa77de35d3')
build() {
- cd "$pkgname-$pkgver"
-
+ cd "${pkgname}-${pkgver}"
+
./configure \
- prefix="$pkgdir/usr" \
-
+ --prefix='/usr' \
+ --enable-largefile \
+ --enable-ssl \
+ --enable-gnutls \
+ --enable-cdsassl \
+ --enable-localjpeg \
+ --enable-localzlib \
+ --enable-localpng \
+ --with-gui
+
make
}
package() {
- cd "$pkgname-$pkgver"
-
- make install
-
- # documentation
- install -d "$pkgdir/usr/share/doc/htmldoc"
- for f in CHANGES.txt README.txt; do
- install -Dm644 $f \
- "$pkgdir/usr/share/doc/htmldoc/$f"
- done
-
- # desktop file
- install -Dm644 desktop/htmldoc.desktop \
- "$pkgdir/usr/share/applications/htmldoc.desktop"
-
- # icons
- for s in 16 24 32 48 64 96 128; do
- install -Dm644 desktop/htmldoc-${s}.png \
- "$pkgdir/usr/share/icons/hicolor/${s}x${s}/apps/htmldoc.png"
- done
-
- # mime
- install -Dm644 desktop/htmldoc.xml \
- "$pkgdir/usr/share/mime/packages/htmldoc.xml"
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
}
diff --git a/errno.patch b/errno.patch
deleted file mode 100644
index f0595481df6d..000000000000
--- a/errno.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Nu htmldoc-1.8.28/htmldoc/http-addrlist.c htmldoc-1.8.28_fixed/htmldoc/http-addrlist.c
---- htmldoc-1.8.28/htmldoc/http-addrlist.c 2011-12-30 02:41:10.000000000 -0500
-+++ htmldoc-1.8.28_fixed/htmldoc/http-addrlist.c 2014-02-27 18:08:04.000000000 -0500
-@@ -28,6 +28,7 @@
- # include <resolv.h>
- #endif /* HAVE_RESOLV_H */
-
-+#include <errno.h>
-
- /*
- * 'httpAddrConnect()' - Connect to any of the addresses in the list.
diff --git a/htmldoc.install b/htmldoc.install
deleted file mode 100644
index f1b73efac3e7..000000000000
--- a/htmldoc.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- update-desktop-database -q
- update-mime-database /usr/share/mime &> /dev/null
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}