summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2016-08-22 09:58:39 +0200
committerMassimiliano Torromeo2016-08-22 09:58:39 +0200
commit3ee378b37623371562a0bcb8c538750a53e5487a (patch)
treeaf8fc559674c74ddce2291891e37fe910aefb10d
parentf3036ae19e4aa1aad7546e344711599175df86cf (diff)
downloadaur-3ee378b37623371562a0bcb8c538750a53e5487a.tar.gz
Updated to 0.9.12 and renamed to htmlhint
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD16
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4256adc84097..b88b5c15c9e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,20 @@
-pkgbase = nodejs-htmlhint
+# Generated by mksrcinfo v8
+# Mon Aug 22 07:57:58 UTC 2016
+pkgbase = htmlhint
pkgdesc = Static Code Analysis Tool for HTML, you can use it with IDE or in build system.
- pkgver = 0.9.7
+ pkgver = 0.9.12
pkgrel = 1
url = http://htmlhint.com/
arch = any
license = MIT
makedepends = npm
depends = nodejs
- noextract = htmlhint-0.9.7.tgz
- source = http://registry.npmjs.org/htmlhint/-/htmlhint-0.9.7.tgz
- sha256sums = 23b7df7531b1a0876c6724fb1e5e25990a0eec0153978ec4fed5d6e280759f71
+ provides = nodejs-htmlhint
+ conflicts = nodejs-htmlhint
+ replaces = nodejs-htmlhint
+ noextract = htmlhint-0.9.12.tgz
+ source = http://registry.npmjs.org/htmlhint/-/htmlhint-0.9.12.tgz
+ sha256sums = 54c2c05282bd4b406cad143be1c8c4494c3b27643ddaa78610270aada4ff2006
-pkgname = nodejs-htmlhint
+pkgname = htmlhint
diff --git a/PKGBUILD b/PKGBUILD
index ce0da2508ab7..cba2b70d0170 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
-_npmname=htmlhint
-pkgname=nodejs-htmlhint
-pkgver=0.9.7
+pkgname=htmlhint
+pkgver=0.9.12
pkgrel=1
pkgdesc="Static Code Analysis Tool for HTML, you can use it with IDE or in build system."
arch=(any)
url="http://htmlhint.com/"
license=('MIT')
+provides=('nodejs-htmlhint')
+replaces=('nodejs-htmlhint')
+conflicts=('nodejs-htmlhint')
depends=('nodejs')
makedepends=('npm')
-source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
-noextract=($_npmname-$pkgver.tgz)
-sha256sums=('23b7df7531b1a0876c6724fb1e5e25990a0eec0153978ec4fed5d6e280759f71')
+source=(http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
+noextract=($pkgname-$pkgver.tgz)
+sha256sums=('54c2c05282bd4b406cad143be1c8c4494c3b27643ddaa78610270aada4ff2006')
package() {
- npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/$_npmname-$pkgver.tgz
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$pkgver.tgz
rm -rf "$pkgdir"/usr/etc
chmod -R go-w "$pkgdir"
install -Dm0644 "$pkgdir"/usr/lib/node_modules/htmlhint/LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.md