summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-09-18 20:35:09 +0200
committerKr1ss2021-09-18 20:35:09 +0200
commit343b833d992f4ecc77c950bc0147b408c5573da3 (patch)
tree4dc24889cb1bedcdb762049150dc9b220c39c6cc
parent95f5626c416a9832a8917a9d589a1456e63c3987 (diff)
downloadaur-343b833d992f4ecc77c950bc0147b408c5573da3.tar.gz
update: htmlunit 2.53.0-1
upstream release split out documentation as an extra package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index def69ff0fc79..485042d40003 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = htmlunit
pkgdesc = Headless HTTP webclient for Java
- pkgver = 2.52.0
+ pkgver = 2.53.0
pkgrel = 1
url = http://htmlunit.sourceforge.net
arch = any
license = Apache
- depends = java-runtime-common
- source = https://github.com/htmlunit/htmlunit/releases/download/2.52.0/htmlunit-2.52.0-bin.zip
- sha256sums = 30082ede9542b0205dfc50999fe6bef6dae233b1de6d615dc78bf8fe6f411164
+ source = https://github.com/htmlunit/htmlunit/releases/download/2.53.0/htmlunit-2.53.0-bin.zip
+ sha256sums = 9b455d3489f1de73503cef23e66f8d60a61b302e29f3231675116a3761e62f3d
pkgname = htmlunit
+ depends = java-runtime-common
+ optdepends = htmlunit-doc: API documentation
+
+pkgname = htmlunit-doc
diff --git a/PKGBUILD b/PKGBUILD
index 3f9845eece48..547b956599be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,33 @@
# Contributor : Joel Sevilleja Febrer Joel7987[at].gmail.com
-pkgname=htmlunit
+pkgbase=htmlunit
+pkgname=("$pkgbase" "$pkgbase-doc")
-pkgver=2.52.0
+pkgver=2.53.0
pkgrel=1
pkgdesc='Headless HTTP webclient for Java'
arch=('any')
-url="http://$pkgname.sourceforge.net"
+url="http://$pkgbase.sourceforge.net"
license=('Apache')
-depends=('java-runtime-common')
+#source=("http://sourceforge.net/projects/$pkgbase/files/$pkgbase/$pkgver/$pkgbase-$pkgver-bin.zip")
+source=("https://github.com/$pkgbase/$pkgbase/releases/download/$pkgver/$pkgbase-$pkgver-bin.zip")
+sha256sums=('9b455d3489f1de73503cef23e66f8d60a61b302e29f3231675116a3761e62f3d')
-#source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver-bin.zip")
-source=("https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver-bin.zip")
-sha256sums=('30082ede9542b0205dfc50999fe6bef6dae233b1de6d615dc78bf8fe6f411164')
+package_htmlunit() {
+ depends=('java-runtime-common')
+ optdepends=("$pkgbase-doc: API documentation")
-package() {
- cd "$pkgname-$pkgver"
- install -Dm644 lib/*.jar -t"$pkgdir/usr/share/java/$pkgname/"
- install -dm755 "$pkgdir/usr/share/doc"
- cp -a --no-preserve=o apidocs "$pkgdir/usr/share/doc/$pkgname"
+ cd "$pkgbase-$pkgver/lib"
+ install -Dm644 *.jar -t"$pkgdir/usr/share/java/$pkgbase/"
+}
+
+package_htmlunit-doc() {
+ install -dm755 "$pkgdir/usr/share/doc"
+ cp -a --no-preserve=o "$pkgbase-$pkgver/apidocs" "$pkgdir/usr/share/doc/$pkgbase"
}