summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2022-04-25 22:47:13 +0200
committerKr1ss2022-04-25 22:47:13 +0200
commit3952f91173f292941785d7c8dbee944dac116d86 (patch)
tree153868c63c9daf935e9a0658d970c36f4b7b6884
parent5d0e8c747fcdd298606e7059ed7787442f969fcd (diff)
downloadaur-3952f91173f292941785d7c8dbee944dac116d86.tar.gz
update: htmlunit 2.61.0-1
upstream release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5755d46ca5b3..9cc4c1ae20e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = htmlunit
pkgdesc = Headless HTTP webclient for Java
- pkgver = 2.60.0
+ pkgver = 2.61.0
pkgrel = 1
- url = http://htmlunit.sourceforge.net
+ url = http://.sourceforge.net
arch = any
license = Apache
- source = https://github.com/htmlunit/htmlunit/releases/download/2.60.0/htmlunit-2.60.0-bin.zip
- sha256sums = 9f3eaf5226245477d7a8111b022f24d8b01d70f6bb8b611e1a24dd7bd71e7676
-
-pkgname = htmlunit
depends = java-runtime
- optdepends = htmlunit-doc: API documentation
+ provides = htmlunit-doc
+ conflicts = htmlunit-doc
+ replaces = htmlunit-doc
+ source = https://github.com/htmlunit//releases/download/2.61.0/htmlunit-2.61.0-bin.zip
+ sha256sums = 292b527fb77e1470428c5b7e8363d16146e6d28af6ad97ce5ad76ccfd933f59e
-pkgname = htmlunit-doc
+pkgname = htmlunit
diff --git a/PKGBUILD b/PKGBUILD
index d77c7b2332d6..a556c19b0534 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,9 @@
# Contributor : Joel Sevilleja Febrer Joel7987[at].gmail.com
-pkgbase=htmlunit
-pkgname=("$pkgbase" "$pkgbase-doc")
+pkgname=htmlunit
-pkgver=2.60.0
+pkgver=2.61.0
pkgrel=1
pkgdesc='Headless HTTP webclient for Java'
@@ -14,22 +13,22 @@ arch=('any')
url="http://$pkgbase.sourceforge.net"
license=('Apache')
-#source=("http://sourceforge.net/projects/$pkgbase/files/$pkgbase/$pkgver/$pkgbase-$pkgver-bin.zip")
-source=("https://github.com/$pkgbase/$pkgbase/releases/download/$pkgver/$pkgbase-$pkgver-bin.zip")
-sha256sums=('9f3eaf5226245477d7a8111b022f24d8b01d70f6bb8b611e1a24dd7bd71e7676')
+provides=("$pkgname-doc")
+conflicts=("$pkgname-doc")
+replaces=("$pkgname-doc")
+depends=('java-runtime')
-package_htmlunit() {
- depends=('java-runtime')
- optdepends=("$pkgbase-doc: API documentation")
+#source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver-bin.zip")
+source=("https://github.com/$pkgname/$pkname/releases/download/$pkgver/$pkgname-$pkgver-bin.zip")
+sha256sums=('292b527fb77e1470428c5b7e8363d16146e6d28af6ad97ce5ad76ccfd933f59e')
- cd "$pkgbase-$pkgver/lib"
- install -Dm644 *.jar -t"$pkgdir/usr/share/java/$pkgbase/"
-}
-package_htmlunit-doc() {
- install -dm755 "$pkgdir/usr/share/doc"
- cp -a --no-preserve=o "$pkgbase-$pkgver/apidocs" "$pkgdir/usr/share/doc/$pkgbase"
+package() {
+ cd "$pkgname-$pkgver/lib"
+ install -Dm644 *.jar -t"$pkgdir/usr/share/java/$pkgname/"
+ #install -dm755 "$pkgdir/usr/share/doc"
+ #cp -a --no-preserve=o "$pkgname-$pkgver/apidocs" "$pkgdir/usr/share/doc/$pkgname"
}