summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYardena Cohen2024-03-28 17:55:43 -0700
committerYardena Cohen2024-03-28 17:55:43 -0700
commit1dd90843ef8bc62d5e024ece5cf2b4f76f7530a8 (patch)
treebbb1d0e162008614be2ef080736eae2d20a03eb3
parent2f7464b192add7af9db62e2cf49b765b8dbcee99 (diff)
downloadaur-htop-git.tar.gz
fix depends, license, version format
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceb16752a0b7..26bbe4520a16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = htop-git
pkgdesc = Interactive text-mode process viewer
- pkgver = 3.3.0.23.g4abe9f4c
+ pkgver = 3.3.0.r64.gef6658c2
pkgrel = 1
epoch = 1
- url = https://htop.dev
+ url = https://github.com/htop-dev/htop
arch = i686
arch = x86_64
- license = GPL
+ license = GPL-2.0-or-later
makedepends = git
- makedepends = python
- depends = ncurses
+ makedepends = lm_sensors
+ depends = libcap
+ depends = libcap.so
depends = libnl
+ depends = ncurses
+ depends = libncursesw.so
optdepends = lsof: list open files for running process
optdepends = strace: attach to running process
optdepends = lm_sensors: temperature monitoring
diff --git a/PKGBUILD b/PKGBUILD
index 99e77e0d5ac7..40e29549c196 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,27 @@
gitname=htop
pkgname=${gitname}-git
-pkgver=3.3.0.23.g4abe9f4c
+pkgver=3.3.0.r64.gef6658c2
pkgrel=1
epoch=1
pkgdesc="Interactive text-mode process viewer"
-url="https://htop.dev"
-license=('GPL')
+url="https://github.com/htop-dev/htop"
+license=('GPL-2.0-or-later')
arch=('i686' 'x86_64')
-depends=(ncurses libnl)
-makedepends=('git' 'python')
+depends=('libcap' 'libcap.so' 'libnl' 'ncurses' 'libncursesw.so')
+makedepends=('git' 'lm_sensors')
optdepends=('lsof: list open files for running process'
'strace: attach to running process'
'lm_sensors: temperature monitoring')
provides=('htop')
conflicts=('htop')
options=('!emptydirs')
-source=("git+https://github.com/htop-dev/htop.git")
+source=("git+$url.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${gitname}"
- local ver="$(git describe --tags)"
- printf "%s" "${ver//-/.}"
+ git describe --long --tags --abbrev=8 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {