summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryar2014-04-29 14:51:24 -0700
committeryar2015-06-11 20:10:22 -0700
commitf6eee60491225a7a4c6c6a91f7fa60b76f6c5de0 (patch)
treeb034f69c5d1aa03f2cc5bbe239e40ad9f5e134f7
parent877a6d3de63726cb738bc4976fac5324b5201964 (diff)
downloadaur-f6eee60491225a7a4c6c6a91f7fa60b76f6c5de0.tar.gz
[htop-git] drop merged patch, bump
[htop-git] patch processlist to fix build [htop-git] use prepare() correctly [htop-git] remove processlist patch, it's upstream now Back in '14 I added a patch, but stupidly forgot to add it to version control. It was ignored. I think I lost it forever. Now AUR4 won't let me push these commits because it's missing. So let's pretend it never happened.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f38a7cb9e1a8..95796f13e6a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = htop-git
pkgdesc = Interactive text-mode process viewer
- pkgver = 312.953ec71
+ pkgver = 383.f0e2a0e
pkgrel = 1
url = https://github.com/hishamhm/htop
arch = i686
@@ -15,9 +15,7 @@ pkgbase = htop-git
conflicts = htop
options = !emptydirs
source = git+https://github.com/hishamhm/htop.git
- source = https://projects.archlinux.org/svntogit/packages.git/plain/htop/trunk/tree-crash.patch
- md5sums = SKIP
- md5sums = 48eba3c0303bfd19d761b859bc69d713
+ sha256sums = SKIP
pkgname = htop-git
diff --git a/PKGBUILD b/PKGBUILD
index 808c1f23f21f..c51564b6e779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
gitname=htop
pkgname=${gitname}-git
-pkgver=312.953ec71
+pkgver=383.f0e2a0e
pkgrel=1
pkgdesc="Interactive text-mode process viewer"
url="https://github.com/hishamhm/${gitname}"
@@ -13,9 +13,8 @@ optdepends=('lsof: list open files for running process'
provides=('htop')
conflicts=('htop')
options=('!emptydirs')
-source=("git+${url}.git"
- "https://projects.archlinux.org/svntogit/packages.git/plain/htop/trunk/tree-crash.patch")
-md5sums=('SKIP' '48eba3c0303bfd19d761b859bc69d713')
+source=("git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${gitname}"
@@ -23,7 +22,7 @@ pkgver() {
printf "%s" "${ver//-/.}"
}
-build() {
+prepare() {
cd "${srcdir}/${gitname}"
./autogen.sh
@@ -31,10 +30,6 @@ build() {
sed -i 's|ncursesw/curses.h|curses.h|' RichString.[ch] configure
sed -i 's|python|python2|' scripts/MakeHeader.py
- # Boost field buffer size - crashes when trying to draw very deep UTF-8 trees
- # Test by nesting 30 shells
- patch -N -i "${srcdir}/tree-crash.patch"
-
./configure \
--prefix=/usr \
--enable-unicode \
@@ -42,7 +37,10 @@ build() {
--enable-vserver \
--enable-cgroup \
--enable-oom
+}
+build() {
+ cd "${srcdir}/${gitname}"
make
}